Metal Messiah

Members
  • Публикации

    43
  • Зарегистрирован

  • Посещение

Репутация

1 Обычный

О Metal Messiah

  • Звание
    Новенький

Информация

  • Город
    Украина

Электроника

  • Стаж в электронике
    1-2 года
  • Оборудование
    Китайский мультиметр и китайский паяльник

Посетители профиля

300 просмотров профиля
  1. Релейная сборка - помогите заставить работать

    Согласен, надо было сразу нарисовать измеренные напряжения прямо на схеме.
  2. Релейная сборка - помогите заставить работать

    А вот петросянить не нужно. Проблема с транзисторами была еще на момент создания темы, а закорачивать их, проверяя включится ли реле, я начал только к пятому посту. "При мне" ушел только VT1. И без подачи питания на схему подключал только катушку реле к переключаемому источнику 3-6-9-12 вольт, от 3, естественно, не работало но от 6 и 9 шло. По идее, так можно. Вопрос в том что контроллер работает от 6-12 (не более 40, кажется) вольт, и если все лишнее гасится стабилизаторами то зачем - можно же вообще всю систему запитать от 9...
  3. Релейная сборка - помогите заставить работать

    Да когда-то в детстве телемастер при мне выпаял импульсным паяльником какую-то емкость секунды за полторы, а на мой возглас в стиле "нихренасе че так быстро" сказал что это импульсный, но в компьютеры им лазить не стоит, может что повредить. Т.е. компьютерные платы им паять вроде как нельзя. Факт был в том что VT2 не пахали изначально.
  4. Релейная сборка - помогите заставить работать

    Можно было и не рисовать, я не тупой, как бы это могло показаться, а напряжения в запрошенных точках вокруг транзисторов были еще в 1 посте, только я это не сильно наглядно описал и не мог понять чего еще от меня хотят. Понятно, спасибо. Можно еще вангануть из за чего все VT2 так дружно полетели? (VT1 не в счет, это мог быть уже результат моих криворуких тыканий проводом куда попало). КЗ находилось между дорожкой-общим и дорожкой +12в, которые на плате идут параллельно и близко у друг другу, в месте припаивания катушки реле К1 к красному и/или в месте припаивания контакта разъема. Скорее всего и, и по поводу контакта - точно, потому что прошло только после подрезания возле него, а у реле может и действительно пайка поверх лака была. В маловероятном 1 случае ток бы шел вдоль 2 параллельных дорожек до места, во втором все еще проще - кз прямо на разъеме, ток по плате не бродил совсем. Превышения напряжения не было, источник стабильный. Прямо на заводе на ленте поставили пробитые транзисторы и нет никакого тестирования изделий? Могло быть из-за использования импульсного паяльника в месте припаивания К1 к дорожке питания? Путем экспериментов установил что поштучно реле дергаются и от 6, и от 9 вольт. Понятно что все 4 параллельно 6 может не потянуть и просесть. На самих написано что катушка 12В. Должна ли вся система работать от 9 вольт?
  5. Релейная сборка - помогите заставить работать

    Еще когда 1й был жив а 2й вел себя точно так же у меня была такая мысль, но тогда почему K3 и K4 не реагируют на изменение уровня на пинах коннектора (3.3 против 0, дальше на базе соответственно 0.68 или 0)? Точнее VT1 как раз реагируют и на их коллекторе напряжение меняется, но VT2 дальше не отрабатывают. Дохлые все VT2 но по разному? Изначально как я уже писал было короткое по питанию, между дорожками, могу показать на фото где я подрезал. Но ток КЗ не шел через детали, он по сути проходил только по дорожкам и шлейфу, соединявшему эту плату с контроллером, потому не понимаю какого черта транзисторы не рабочие.
  6. Релейная сборка - помогите заставить работать

    Прикладываю, на полной схеме все отмечено. Это то что нужно? Собственно числа похожие на те что я давал в 1 посте. В 5 посте все то же но при разных логических уровнях на пинах коннектора. Единственное существенное отличие от того что было раньше - VT1 в цепи К1 сдох, причем видимо непосредственно до того как происходило то что я описал раньше как " но так заводится только 1е реле, остальные молчат", видимо, уже на тот момент было неисправно. Транзисторы VT1 от К2, К3, К4 точно рабочие т.к. при изменении состояния логики там где 0V (транзистор открыт на землю) появляется напряжение порядка 10v
  7. Релейная сборка - помогите заставить работать

    Дык проблемы везде. 2й канал отличается от остальных но если бы он работал остальные нет или наоборот было бы понятно. Теперь и транзистор VT1 1го реле тоже, но тут бы хотя бы 3 рабочих...
  8. Релейная сборка - помогите заставить работать

    Так в 1 посте и есть схема, она абсолютно одинаковая для 4 реле потому не дублировал. Точки U2 U3 U4 замерялись. На эмиттерах нули, они на земле сидят, базы и коллекторы написал выше
  9. Релейная сборка - помогите заставить работать

    На долю секунды для теста щелк - не щелк обычно было можно. т.е. оно проходит с коллектора на базу в обратном направлении?
  10. Релейная сборка - помогите заставить работать

    Да мне проще поменять местами контакты или 0 с 1 в программе Сам школьник-радиолюбитель, уже понимаю как оно должно работать но не понимаю откуда левые напряжения. Руки чешутся выкинуть все SMD дерьмо и поставить 4 нормальных транзистора
  11. Релейная сборка - помогите заставить работать

    Да я бы выкинул весь второй "контур" и подключил реле на VT1 напрямую, делал такое с портом компа, несколько лет стабильно работало. Навороты бессмысленные, 0 с 1 перепутаны, но в софте это проще поменять чем лишние транзисторы ставить.
  12. Релейная сборка - помогите заставить работать

    Самое интересное что такое дерьмо приходит от поставщика, и это вторая, потому как первая расплавилась в хлам после включения питания. Пока еще не ответили либо это партия брак либо что. Короче предлагаете поменять все транзисторы и не иметь себе мозги?
  13. Релейная сборка - помогите заставить работать

    Да, относительно общего. Общую проверил, все 8 эмиттеров связаны с клеммой минуса. Взял трансформаторный источник 3V номиналом (без нагрузки выдает около 6), минус соединил жестко, плюсом тыкаю куда придется, обнаруживаю интересные вещи. Если тыкнуть по точке U2 - реле №1,3,4 заводится, если по верхней (по схеме) стороне катушки - то еще громче, при этом на базу VT2 ничего заведомо не подается, ток идет через катушку или диод, потом R3, R4 и приходит на базу транзистора. Второе реле таким образом не заводится. Если этими же 3 вольтами тыкнуть на базу VT2, по идее, ток должен открывать транзистор и параллельно идти через R4, R3, потом катушку реле - но так заводится только 1е реле, остальные молчат. Пытаюсь проверить VT2 от 1го реле. Мультиметр в режим измерения сопротивления, при отсутствии питания показывает между К и Э 3.7кОма, как только на базу подаю 3 вольта - транзистор должен открыться полностью и показать 0 ом, но я получаю наоборот бесконечность (пробовал на делении 200к-то же) P.S. схема VT1 от 1го реле походу представилась, после R1 те же 3 вольта что и до него, транзистор не реагирует на команды с контроллера. На остальных VT1 все как раньше.
  14. Релейная сборка - помогите заставить работать

    Еще немного посоображал мозгами. Если программа выдает на вход "1" (напряжение 0.11V) оно подходит к базам всех VT1 и они закрыты, на коллекторе ("голове") напряжение около 10+ вольт. Если на выходе "0" (3.3V) то VT1 открываются и на их головах становится 0 (по сути соединено с землей). Значит первая партия ключей (все VT1) рабочие. Дальше интереснее. На базах VT2 все напряжения разные. При всех "0" (3.3V на шлейфе, все VT1 открыты) это 10.34V, 2.57V, 10.75V, 9.60V (2 у того который щелкает сразу при появлении питания, остальные реле в исходном положении). Если поставить всем "1" (т.е. закрыть VT1) то это 11.65V, 2,46V, 11.67V, 11.45V соответственно. На базах что так что так много вольт и VT2 по идее должны быть открыты. При этом если я закорачиваю проводом коллектор и эмиттер VT2 №1,3,4 (по сути открываю транзистор) то соответствующее реле щелкает (№2 не реагирует, значит все транзисторы VT2 закрыты кроме №2 и если руками открыть - реле щелкает). Почему они закрыты если на базах высокие напряжения? Если базу VT2 закорачиваю на землю у №1,2,3 - тоже реле дергаются. Тут я уже не понял, вроде не должно работать и так и так. Реле №2 дергается только если на базу его VT2 подать +12 с дорожки питания. На этом у меня голова перестает варить потому что я думаю что все это должно быть наоборот. На всякий случай прикладываю фото платы, вдруг кто увидит невидимые дорожки. Земля проходит между ногами чуть ли не каждого резистора, что сильно разрывает мозг.
  15. Добрый вечер. Отреверсил заводской брак - плата на 4 реле с транзисторной обвязкой. Изначально было КЗ по питанию, сопля между супер-близко расположенными дорожками (на месте где припаяна катушка реле к +, там же впритык проходит -), хотя и покрытыми сверху лаком, и что-то похожее на месте припаивания контакта коннектора. По крайней мере начал с сопли, потом уже подпилил ножем коннектор и только после этой второй операции КЗ пропало (при этом сосед сказал что я дурак и первую точку вообще трогать не нужно было потому что пайка поверх лака дорожки не касалась - но тут хз он не больше меня в этом соображает). Дальше включаю туда куда оно должно включаться в контроллер (на всех выводах шлейфа +3.3V т.е. состояние реле должно быть одинаковым, открытым либо закрытым пока черт знает). Оказывается что №1, 3, 4 в исходном положении (в том же которое без питания) а №2 шелкнуло в противоположное положение. Дальше замеряю напряжения в контрольных точках (на схеме). U1 по питанию - 11.66V везде U2 на коллекторе VT2 - 10.85V на всех, 3.96V на том что включилось U3 на базе VT2 - 10.3V на всех, 2.6 на включенном U4 на базе VT1 - 0.7V на всех Реле объявлены 12-вольтовые. На резисторах R3 на всех разность потенциалов равна U1 т.е. VT1 все открыты (потому что на шлейфе на всех пинах +3.3V?). На базе VT2, как выше написал, напряжение есть, но с обратной стороны резисторов R4 его нет т.к. VT1 открыт. Откуда взялось напряжение на базе VT2 я не понял, других дорожек на плате хоть убей не вижу. Помогите понять как оно вообще должно работать и как заставить работать. В распиновке транзисторов я не уверен, информацию конкретно по этим не нашел, ванганул по похожим. На плате 4 комплекта абсолютно одинаковой логики, потому на схеме только один из них. Все резисторы прозванивались в выключенном состоянии и соответствуют номиналам. Плата включалась в сеть до обнаружения КЗ, но предполагая такую дрянь делалось это на секунду пока под пальцем не стало тепло. Ток шел между дорожками напрямую, потому не думаю что он бы повредил детали этой платы. Контроллер живой - на выходе выдает нужные напряжения в зависимости от установленных программой состояний.