zoom-0

Members
  • Content count

    239
  • Joined

  • Last visited

Community Reputation

4 Обычный

About zoom-0

  • Rank
    Постоялец

Информация

  • Пол
    Мужчина
  • Город
    Рязань

Электроника

  • Стаж в электронике
    Не связан с электроникой

Recent Profile Visitors

4043 profile views
  1. спасибо за ответ, ( ничЁсе скока циферок в коде... каждое деление прописали...) но сделал немного по другому, у кого-то из скетча дернул кусок : if (recieved_data[0] >=128 && recieved_data[0] <=189)data = recieved_data[0], bspeed = map(data, 189, 128, 255, -255), backward(bspeed); if (recieved_data[0] >=201 && recieved_data[0] <=255)data = recieved_data[0], fspeed = map(data, 255, 201, 255, -255), forward(fspeed); if (recieved_data[0] >190 && recieved_data[0] <200)data = recieved_data[0], stop(); тоже поставил н-мост (но схема другая, тоже на 6 транзюках) и вот тут началось... спаял... транзисторы сами немного открываются , двигатель покряхтывает, потом начинает крутиться , и все это при условии, что я никаких команд ему не даю. спаял три моста, менял резисторы. В разных мостах делал разные транзисторы. (кт816-817 / 805-837 / 972-973 ) результат всегда один - транзисторы открываются без сигнала и одна пара жутко греется. выпаял все из платы - собрал на макетке ( что бы легче резисторы подбирать ), а подбирать ничего не нужно ! на макетке работает идеально ! спаял снова на другой плате... и опять греется и сами открываются. плату помыл. не помогло. Плюнул на эстетичность, собрал опять , но уже на маленькой макетке, и макетку запихал в машину :). все работает.
  2. Всем здравствуйте. Народ, подскажите в таком деле. Как заставить один мотор при управлении джойстиком изменять мощность и направление? Вся суть такая: собрал пульт на ардуино с передатчиком nrf24l01 ,на пульте есть два джойстика - один джойстик управляет двумя серво по осям, на втором джойстике ось Х сервомотор поворота передних колес , а ось Y это будет основной мотор, вот его не могу заставить крутиться как нужно. Это будет радиоуправляемая машина. То есть от джойстика она должна ехать с регулировкой мощности (скорости ) вперед и назад от центральной точки джойстика. Пробовал прописать : ...(joyY), 0, 1023, -255, 255)... но в этом случае по шим ключ-мосфет работает только от 0 в сторону +255 и то как-то не корректно. подскажите как правильно написать : если джойстик в среднем потожении (+- 5 градусов) мотор выключен, если в сторону +255 едем вперед, если в сторону -255 едем назад. Как правильно прописать команду если ,к примеру, я хочу вывести значения движения вперед на 6pin (шим) , а значения движения назад на 5pin (шим). Два этих выхода я подкину к драйверу двигателя. { if (digitalRead(joyY), 500, 520, 0, 0) digitalWrite(6,LOW) digitalWrite(5,LOW) if (digitalRead(joyY), 521, 1023, 0, 255) digitalWrite(6,0, 255) digitalWrite(5,LOW) if (digitalRead(joyY), 0, 499,0, 255) digitalWrite(6,LOW) digitalWrite(5,0, 255) } вот так верно будет ?
  3. Народ, день добрый, кто в теме, подскажите. у какого осцилла меньше погрешность , понятно что оба не айс, просто нужен ответ у ардуиновского (отсюда) или DSO150 (вот такой)
  4. Проблему решил. ( по детски ), разобрал. включил , он написал ошибку пин#6 или пин#9, я думаю непропай где-то наверное. Погрел феном без фанатизма. Собрал все назад. Все работает. Надеюсь надолго. В прошлом году когда он так бегал по секторам он тоже потом ошибку какого-то пина выдавал, но потом сам заработал. Я думаю может еще от того что я корпус почти герметичным старался сделать ( от дождя , мокрой травы...) но гнезда все открыты. Возможно влага попала, но не вышла, и осела где-то мелкой окисью.
  5. доброго времени, народ, подскажите в таком вопросе : работал квазар исправно и хорошо года два. Однажды за это время при включении начал плясать сигнал по всем секторам, то там , то сям, издавая музыкальную какофонию. Выключил... через час включил, все хорошо. А недавно включил и опять сигнал бегает по секторам попискивая везде от железа до меди... Все это происходит в поле... чистом поле. При обнаружении металлов пищит как положено, но эти постоянные ложняки идут бесперебойно. Прибор покупной. Осциллографа у меня нет. Можно при помощи тестера починить? На что обратить внимание? Прибор сбросил, отстроил, перестроил... ложняки... Или просто катушка умерла ? ( при отключении катушки в приборе тишина )
  6. начал менять емкости. Заменил пару, потом обнаружил на одном кондерчике ( 1мкф-50в ) "холодную пайку", пропаял. Все работает. Подключил строительный фен ( 2000 Вт ) на слабом режиме, все отлично. Всем спасибо за помощь ! ( где в репу плюсануть не найду )
  7. Что бы сделать Правильные замеры нужно знать где мерить :), Завтра заменю емкости, если не поможет составлю карту напряжений выводов микросхемы и транзисторов в режиме работы и когда блокируется. ( указанное место проверю тоже ).
  8. то, что я выложил это практически вся схема. Еще трансформатор и вольтметр... и усё
  9. да, там видимо нагрев стабилитрона, я там первым делом пропаял контакт стабилитрона ( диода ? ) и резистор рядом. Эффекта не последовало. Завтра тогда просто поменяю все емкости. И если найду на нем маркировку, стабилитрон.
  10. Да нет, вы не так видимо поняли. Он уходит ,как я понял, в защиту от "козы" и клацает реле. А дело было так... Работал он очень хорошо 8-9 лет ! вчера вырубился ( я думаю ушел в защиту ), отключили, подождали, включили. Сутки поработал и вырубился опять. Сейчас работает если нагрузка очень маленькая - зарядка телефона, блок питания на 30 вт. и тп. , а если подключить что-то мощнее 100-150 Ватт , то он вырубается. Стрелка индикатора падает на ноль и релюшка клацает постоянно (0,8-1,5 сек ), во время клацанья релюшки стрелка пытается дернуться , но возвращается на ноль. Поэтому я и решил, что просто он любую нагрузку выше 100-150 Ватт считает перегрузом и уходит в защиту. ( мощность котла по паспорту 120-150 Вт ) ЗЫ. котел газовый. там нагрузки-то пара двигателей и электро-клапан. Сейчас поставили временно другой стабилизатор но 240 Ватт. Работает. Котел не виноват
  11. Товарищи, такая проблемка нарисовалась. Есть у меня стабилизатор. через него подключен котел. А сейчас стабилизатор вырубается под нагрузкой . Стабилизатор СПНБ-1000-Р схема вроде простенькая, но в и-нете не нашел. Кто знает подобные схемы , какая обвязка отвечает за защиту и выключение при перегрузке ? извиняюсь, не нашел где под спойлер спрятать...
  12. нашел схему, по которой собирал.
  13. Обвязка почти по даташиту и схемам выше. Какие выводы микросхемы отвечают за ток? На каких ногах перебрать (изменить) обвязку? При нагрузке выше двух ампер , не важно как включать, сначала нагрузку потом БП или наоборот. Всегда блокируется.
  14. товарищи, такая проблема: собрал регулируемый блок питания из АТХ на 6105, все работает, но при нагрузке выше двух ампер уходит в режим защиты. подскажите в какой цепи подкрутить, что бы увеличить максимальный ток срабатывания ?