graffon

Ремонт Щитка Приборов Квадроцикла

13 сообщений в этой теме

graffon    0

Здравствуйте!! Очень нужна помощь знатоков!!!!

Ситуация следующая,привезли приборку от квадрацикла,модель не знаю. Не работает дисплей,точнее не прорисовываются некоторые сегменты. Приборка сделана на базе 16-сигментного дисплея,с драйвером PCF8576D и МК 9S12C64.

Дисплей соединен с основной платой через "резинку". Я прочистил металические контакты на плате и периметр "резинового переходника" спиртом.Но сегменты так и не заработали((

Потом раз пять я включил/выключил (от блока питания) спидометр(хотел сфотографировать не работающие сегменты) И вдруг-если раньше при включении зажигались все элементы на секунду,а потом тухли зажигалась надпись приветствия, то сейчас просто зажигаются все сегменты,тухнут и ни че больше не горит.

Так же еще добавлю что в момент когда все еще работало,я проверял осциллографом все 43(если не ошибаюсь) вывода на дисплей,дисплей был снят

.На 4 или 6 были осциллограммы "лесенки" на нескольких питание,а на остальных четкие прямоугольные импульсы с постоянной состовляющей 2.02V А сейчас формы в виде лесенки только на одном выходе

Проверил шину I2C на выходе из МК,есть какая-то генерация,но анализировать ее мне сложно.

Мужики,не пинайте сильно,может что не так написал,я только начинаю заниматься электроникой....но вот такой вот не удачный опыт...

Могло ли что случится с драйвером LCD?? Резинку от самого дисплея на отрывал,она к нему приклеена что ли,побоялся.

Посоветуйте как еще и что можно проверить?? Завтра выложу фотки приборки,они на работе остались.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
KRAB    4 581

Упалил драйвер, даташита не найдешь ... помойка ...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
KRAB    4 581

Тогда осцил и вперед ...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
UTSource

Найдите миллионы труднодоступных

электронных компонентов

graffon    0

Datasheet то без проблем я нашел!! А подскажите,при первом запуске появляются все сегменты...а потом должна быть надпись....так вот ее нет,это из-за драйвера??

И можно по подробнее что там именно проверить осцилом?? Я выше написал что сигналы в форме лесенки как по даташиту присутствут лишь на 1 или2 выводах??

Такя не прорисовка сегментов может быть из-за конченого драйвера?? Или нужно попробовать оторвать резинку от стекла и там прочистить??

post-168090-0-00292300-1421814938_thumb.jpg

post-168090-0-29872300-1421814948_thumb.jpg

post-168090-0-94785600-1421814988_thumb.jpg

post-168090-0-89538400-1421815004_thumb.jpg

post-168090-0-43407600-1421815072_thumb.jpg

Изменено пользователем graffon

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
elki    80

На микрухи все питания приходят? Качай даташиты на них и замеряй. Раз при включении загораются все сегменты это видимо тест дисплея, значит драйвер целый. Либо с мк "слетела" прошивка, либо "слетела" он сам) Раз есть осцилл смотри генерацию на кварцах. Это для начала. Хотя дальше только замена микрух скорее всего, но без прошивки это бесполезно. Питание точно только по двум проводам должно идти? А то может там + постоянно и + при вкл. зажигания на отдельный контакт должен быть? Если так то работать естественно не будет ничего.

Изменено пользователем elki

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
KRAB    4 581

А может и по шине ждет ответа от чего-то ...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
graffon    0

Поменял я проц.моторолла, перед тем как делать какие либо работы,я считал с него прошивку,так вот-поставил новый контроллер,залил туда прошивку......все равно нет результата((((

Питание только по двум проводам...на кан вешал 60ом, на некоторых выходах на дисплей,идет модуляция,сигнал в форме лесенки...но не на всех!

Изменено пользователем graffon

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
forbidden11    75

...я считал с него прошивку...

Проц не залочен был ?

Считалась действительно прошивка или мусор ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
graffon    0

Проц не залочен! Могу дамп скинуть...... Блин куда копать не знаю. И питание на нем есть.. Да и при подаче напряжения зажигаются все сегменты( кроме не рабочих) че делать х.з!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
graffon    0

Вчера сделал наконец таки этот щиток!!! Дамп еепрома слетел.....24с08 ! Заодно и русифицировать получилось!!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
graffon    0

С донора!!! надо,поделюсь!! Только в архиве...как есть залить на форум не получается!! Если кому надо расскажу как русифицировать!!! Но это только в личку......сами понимаете!!

24c08.rar

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас


  • Сообщения

    • Да лампочкой конечно на 220В.   Для начала этот до ума доведи.
    • Зачем вы такие злые? Как могу, так и понимаю... --- В общем и целом запустился, все работает, но... Осликом тыкал без развязки, хорошо не погорел, начинает потом глючить...но это ладно, надо от акума питать... Неисправность довольно непонятная...вышел из строя D015, заменил и все заработало.Проверял диод цешкой, кажет, что рабочий...непонятно. Он соединен не как в схеме, а идет последовательно с D08! Идем дальше... Вентиляторов 2, в момент запуска оба стартуют, потом один (первый) останавливается. Каждый старт, так происходит. Ну думаю, что-то с вентелем случилось. Вот теперь, внимательно, отпаиваю его, а теперь второй стартует и останавливается. Обратно запаиваю, все обратно вернулось...Что за чехарда такая???  И заключительный вопрос. Чем разрядить емкости? В сварочнике у меня стоит 4 банки по 560мкф. Впаивал 3 по 560к 0.5вт не помогает. Сварочник пытается сново запуститься...банки не разряжены!!! или больше резюков надо добавить? -------- Про микру читал...я понимаю, как примерно работает.  Я смотрю на сварочник на схему, снова на сварочник на схему и тут рождается мысль....можно проще сделать и надежнее аппарат...как думаете?
    • Недавича латунь старил в парах нашатыря. Покупается в аптеке. Проверить время выдержки на ненужном кусочке.
    • К примеру такой ШИМ: Его схема такова: Заменив транзисторы на низкоомные (например irfb3207) и пропаяв выводы толстыми шинами, обеспечив ne555 стабильным питанием(батарейка на 12 вольт например к C8), добавив активное охлаждение, добавив ёмкости, схема вытянет и 300 ампер.
    • Дык практически вышеуказанным тросиком, только наматывать его на ось (механизма подачи) в обратном направлении. В качестве рукава для этого тросика возьмите оболочку троса спидометра от какого-нибудь ТАЗика. Да и сам тросик в дело пойдет, только вам  его скорее всего нарастить придется (смотря как трос прокладывать будете от станка и до педали).
    • Если входное напряжение устраивает, то можно попробовать запараллелить 4 штуки. Регуляторами выходного напряжения выставить, чтобы ток делился поровну.