Jump to content
admin

Осциллограф DSO138 - конструктор

Recommended Posts

Нужна помощь с ds0138.

Спаял, экран работает, по меню бегать можно но полезного сигнала нет.

читая эту ветку, решил замерить все что можно:

 

Переключатели:

  • CPL: GND
  • SEN1: 1V
  • SEN2: x5

Напряжения:

  • Питание: 8.65 (питал от +12.4 но грелась U5)  (цель: 9.39V)
  • V+: 5.06 (цель: 8.6V)
  • AV-: -4.99 (цель: -5.0V)
  • AV+: 5.06 (цель: 4.99V)
  • +3.3: 3.30
  • +5V: 5.08
  • V1: 0
  • V1: 3.60 (цель: 1.66V)
  • V3: 3.80
  • TLVL: 1.50
  • L1: -14.75 (гуляет +- 0,2v)
  • V-: -14.60 (гуляет +- 0,2v)
  • J2: 1.65
  • OSC: 2.19

и заодно померил микруху U2:

  1. 0
  2. 0
  3. 0
  4. 5.06
  5. 0
  6. 0
  7. 0
  8. 3.60
  9. 0.24
  10. 0
  11. -4.99
  12. 3.60
  13. 1.50
  14. 3.80

В общем, смущает что AV-: -4.99 AV+: 5.06 немного не такие, как надо.

Ну и L1 и V- 

Если я правильно понимаю схему, то блок питания корректно формирует +3.3 и +5.0. Контроллер и экран нормально работают.

Значит проблема кроется в ОУ ?

Как разобраться где причина, что можно проверить?

 

Share this post


Link to post
Share on other sites

Литиевые ХИТы Fanso: устойчивость к высоким температурам

Литиевые ХИТы для широкого круга применений, в том числе в промышленности, соответствуют требованиям современного рынка и способны работать в самых жестких условиях. Основные требования – это длительность хранения и работы, высокая удельная емкость, а также защита от воздействия таких внешних факторов, как температура и влажность. ЛХИТ превосходят по плотности энергии и нормальному напряжению другие элементы автономного питания: 2,9…3,6 В против 1,2…1,5 В

Читать статью...

возможно кирдык ТЛке, но:

какой у Вас номинал R14?

если все верно и с номиналом и с монтажом R14, R12 - аккуратно поднимите 8-ю ногу ТЛки, замерьте что на линии, а что на чисто 8-й ноге. При 0В на 10-й ноге и положительном потенциале на 9-ой - на 8-й должно быть отриц.напряжение.

на V+  5В ? точно? там же всего один диод.

Share this post


Link to post
Share on other sites

Плавкие предохранители LittelFuse. Грамотный подбор

Выбор оптимального плавкого предохранителя требует учета многих параметров. Для упрощения выбора оптимального предохранителя и автоматизации расчетов Littelfuse предлагает онлайн-утилиту.

Подробнее...

Может, это видео поможет понять где копать?

В момент включения, 2-3 секунды показания меняются.

Может, срабатывает защита?

VID_20170627_090049.mp4

IMG_20170627_090243.jpg

IMG_20170627_090202.jpg

Share this post


Link to post
Share on other sites
17 часов назад, a797945 сказал:

возможно кирдык ТЛке, но:

какой у Вас номинал R14?

если все верно и с номиналом и с монтажом R14, R12 - аккуратно поднимите 8-ю ногу ТЛки, замерьте что на линии, а что на чисто 8-й ноге. При 0В на 10-й ноге и положительном потенциале на 9-ой - на 8-й должно быть отриц.напряжение.

на V+  5В ? точно? там же всего один диод.

да, опечатка. Действительно V+ : 7.85 (сейчас замерил 8.04)

R14: 100 kOm

R12: 122 Om

ногу на ТЛке пока не поднимал - опыта нет, думаю как это сделать безопасно

Share this post


Link to post
Share on other sites
17 часов назад, a797945 сказал:

аккуратно поднимите 8-ю ногу ТЛки, замерьте что на линии, а что на чисто 8-й ноге. При 0В на 10-й ноге и положительном потенциале на 9-ой - на 8-й должно быть отриц.напряжение.

аккуратно поднял 8 ногу,

на самой ноге : 3.8В

на площадке (на соседнем резисторе R12) : -0.28В

на экране теперь нет сигнала (ровной линии), или она сильно "за горизонтом"

изменения по остальным ногам ТЛки:

  • поднятая TL8: 3.8 (-0.28 под ней)
  • TL9: -0.24
  • TL12 -0.28
  • TL14: -4.08

остальные ноги дают те-же уровни.

Share this post


Link to post
Share on other sites

верните 8-ю ногу на место - просто чтобы не подавать на МК через R12, R15 отриц.напряжения.

замкните 9-ю и 10-ю на 8-й должно быть напр. близкое к 0В, точнее к середине питания, хотя и так понятно откуда здесь было большое полож.напр. - ТЛку на замену.

при штатной работе: 10н=0В, 9н=0В, 8н=1.66В (значения не абсолютные, "для справки" - так скажем)

 

Edited by a797945

Share this post


Link to post
Share on other sites

 

В 27.06.2017 в 19:19, a797945 сказал:

замкните 9-ю и 10-ю на 8-й должно быть напр. близкое к 0В, точнее к середине питания, хотя и так понятно откуда здесь было большое полож.напр. - ТЛку на замену.

Заменил ТЛку, все работает!

Спасибо большое за помощь!

Share this post


Link to post
Share on other sites

Подключайте блоки питания на 9в. Через вход а не припаянные провода от кроны на плюс и минус. Я пока не понял в чем дело но были те же симптомы. Белый экран и светодиод мигал. В споре продавец по просил выслать видео. Я подумал что не хорошо провода высылать и достал блок питания. И к моему удивлению изображение появилось.

Edited by Борис Пономарев

Share this post


Link to post
Share on other sites

Рад присоединиться к сообществу.

В общем, собрал сие чудо(не оригинал), правда со второго раза (проблема была в отсутствии Vgen и грелся U5) и сделал работу над ошибками. Возможно для кого то будет интересно. 

  1. Перед началом сборки прозвонил дорожки на наличие КЗ, получил следующие параметры по сопротивлению:
  • GND - V+ =0
    • +3,3 = 955 ом
    • V3 = 1299 ом
    • AV- = 917 ом
    • +5 = 0
    • TLVT = 0
    • V- = 0 

 2. Проверил сопротивление резисторов и смонтировал на плату с контролем КЗ между GND и +3.3

  • R1 = 98.5k
  • R14 = 98,8k
  • R16 = 98,4k
  • R2 = 1760-1720k (гуляет) 
  • R3 = 197,8k
  • R4 = 1949-1958k(гуляет)
  • R5 = 19,80k
  • R6 = 296
  • R7 = 177,4
  • R36 = 178,4
  • R8,12,13  = 119,8
  • R9 = 979
  • R15 = 988
  • R26 = 982
  • R10 = 2,96k
  • R11 = 150
  • R38 = 1470
  • R28,40 = 465
  • R37 = 9,98k
  • R39 = 9,93k 

замер производил китайским мультиметром DT830D

3. Смонтировал индуктивность L1,3,4 - по 4 Ом каждый, L2 = 2,3 Ом, с контролем КЗ между  GND - +3.3 сопротивление  = 871 Ом, после монтажа L2 = 839 Ом, после монтажа U4,5 = 779 Ом.

4. Смонтировал J7,8,9 + переключатели SW1,2,3 с контролем КЗ между GND - +3.3 после припайки каждого пина.

5.Остальное согласно мануалу начиная с пункта 3(монтаж диодов).

6. После монтажа всех компонентов, до подключения питания и экрана, сопротивление GND - +3.3  - 779 Ом

7. Демонтировал перемычку JP4 подключил питание, проверил напряжение в точке +3.3, там 3.3В

8.Смонтировал перемычку JP4 подключил питание(без экрана), прошёлся по точкам, согласно мануала - есть небольшие отклонения(не существенные). Главное есть отрицательное напряжение в пределах нормы.

9. Подключил экран и сделал калибровку согласно мануала.

-Старался не перегревать Q1,2 и U4,5 и не прижимать к плате электролиты в процессе монтажа.

PS На схеме C2 220pF, а в спар листе и по факту 330pF:blink:

PPS Удачи!

 

Share this post


Link to post
Share on other sites

DSO 138 собрал заработал. Потом случайно замкнул какую-то  точку с нижней стороны платы на минус питания. Использовал адаптер там 4 разъёма питания крестом, а 5 как змея на проводе, мне и подгадил). В общем светится подсветка экрана ток 1,1 А. РАспаиваю перемычку JP4 ток 40 ма. Подсветка экрана горит. Вывод замыкание по 3,3 В. А им как я понял только МК питается. МК накрылся? или что ещё проверить

Share this post


Link to post
Share on other sites

Подскажите (не могу найти) на каком контроллере LCD от DSO138 сделан может приспособлю его куда. 

Share this post


Link to post
Share on other sites
37 минут назад, serega374 сказал:

 

Подскажите (не могу найти) на каком контроллере LCD от DSO138 сделан может приспособлю его куда. 

 

ILI9341 так же поддерживаются прошивкой ILI9325/9328

Share this post


Link to post
Share on other sites
В 21.07.2015 в 14:29, krepton85 сказал:

Ну в общем дисплей не работал вообще только подсветка. Как окозалось у меня попался др. модели дисплей, а драйвера в прошивке только в самой последней есть для двух модэлей дисплея. У меня tft дисплей 9325, а раньше были драйвера только для 9341.

Вчера при попытке собрать корпус отломилась катушка L1. Сейчас я включил прибор, припаяв катушку с характеристиками из схемы, но в другом исполнении, но экран мигает белым цветом и все. Никакой информации. Что это может быть? Что делает катушка L1? Или это не из-за неё, а из-за прошивки? На данный момент, из-за кривых рук отвалилась и новая припаянная катушка! Но дисплей также моргает белым цветом. Правда я питаю его от кроны. Тут на форуме пишут что это не есть гуд! Подскажите назначение L1? И ещё вопрос - в комплекте какой щуп идёт обычно- 1:1 или 1:10? 

Подключил бп на 12в. Девайс заработал. Уррраа. Теперь остался только вопрос в роли катушки. И можно ли вместо неё впаять Любой дроссель на 1мкгн/0,5а. Типа LQH1C1R0M04M00-01 или 
EC24-1R0K

Edited by Илья Донсков

Share this post


Link to post
Share on other sites
21 минуту назад, Дмитрий Вас сказал:

L1 это дроссель-трансформатор как в однотактных импульсных бп.

Спасибо. 

Коллеги! Поделитесь схемой простенького делителя 1:10 для dso138. И второй вопрос - куда земля должна подключаться?

моя задача - померять затухание синусоидального сигнала в линии пожарного оповещения. А там 100вольт. Dso со стандартным щупом не возьмёт я так понимаю?

 

сигнал будет 1кгц 100в

Share this post


Link to post
Share on other sites
2 часа назад, Дмитрий Вас сказал:

Нет стандартный не возьмет, а делитель лучше купить.

 

Я бы купил, да срочно нужен. В комплекте оказывается 1:1. А осцилограф оказывается вообще до 5в. А не до 50. Так что мне нужна схема делителя 1:50 или 1:100

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By NikiEss
      Купил простенький осциллограф (1979 года) что бы научиться пользоваться им. Проблема заключается в том что луч на всех диапазонах имеет помехи (см.фото). Также при добавлении ко в ходу щупов идут еще большие помехи на экране (см.фото). Конденсаторы практически все заменил (кроме высоковольтных неполярных). Вопрос - может быть все таки дело в высоковольтных конденсаторах или же проблема в чем то другом? Может кто сталкивался с такой же проблемой. Сам осциллограф на транзисторах, ни одной микросхемы.     




    • By Buba12345
      Здравствуйте всем. 
      Объясните, пожалуйста, максимально простыми словами зачем нужен этот резистор (выделен красным кружком) в схеме инвертирующего усилителя на ОУ. Заранее спасибо!

    • By Buba12345
      Пожалуйста, помогите, надежда только на вас. Завтра сдача по электронной технике (учусь в университете). Предмет я знаю довольно посредственно, так как это совершенно не мой профиль.

      Есть схема неинвертирующего операционного усилителя с однополярным источником питания. По расчетам коэффициент усиления Кус = (1+(R2/R1)) = (1 + (2900/100) = 30. Итого, по расчетам, напряжение на выходе должно быть 0.01В *30 = 0.3 В. Но по вольтметру выходит значение 0.177 В. Скажите, пожалуйста, где я ошибся (коэффициент обязательно по заданию должен быть 30). Я уже и "Искусство схемотехники" посмотрел, и весь интернет перерыл, ничего не могу понять.

      Причем при двуполярном питании выходное напряжение на выходе равно 0.3 (как и должно быть по идее), следовательно, при однополярном соединении. нужно каким-то образом изменить расчеты выходного напряжения (это только мое предположение). 

      Пожалуйста, подскажите, где я ошибся. Буду очень благодарен за помощь! 

    • By Buba12345
      Пожалуйста, подскажите, почему при работе схемы операционного усилителя при однополярном питании синусоида сигнала на выходе на осциллограмме выше нуля? Заранее спасибо за помощь! 
    • By Pelegrim71
      Продаю
      осциллограф, двух лучевой ATTEN ADS1202CAL+ 200МГц -19000 т.р
      генератор VC2002 - 3 т.р
      Все рабочее, пользовался мало.

×
×
  • Create New...