Braimik

Заблокировалась Mega ! Help !

28 сообщений в этой теме

COKPOWEHEU    248

Добавлю немного теории. Программирование происходит по интерфейсу SPI, в котором частоту передачи задает Ведущий (программатор). Но для того чтобы Ведомый успел обработать сигнал, его тактовая частота должна быть хотя бы в 2 раза больше. В вашем же случае частота ведомого всего 33 кГц, что даже меньше частоты SPI.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Быстрый заказ печатных плат

Полный цикл производства PCB по низким ценам!

  • x
    мм
Заказать Получить купон на $5.00
Chewing    0

Мда. Надо было описание программатора читать внимательнее. Спасибо. Теперь прочитал))

А почему не помогло когда я пытался 1,5 МГц подать?

Изменено пользователем Chewing

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Chewing    0

Эффекта ноль от JP3. Ситуация повторяется во всех программах в точности.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас


  • Сообщения

    • Старые 6п3с с фигурным баллоном , осталось : Лампы №1 и №2 по 500р. Лампы № 3, 17, 19  по 800р. ................................................................... Добавлю  , лампы 6ф3п IV-1964г. 8 шт. из ЗИПа  по 120р.  
    • С наводками я разобрался. Но звук двухтактного двигателя все равно возникает,  если работает вся лампа предусилителя. До какого то момента звук прибавляется нормально,  гитара  играет  , если вращать дальше начинается  тарахтение, звук практически пропадает и надо обратно крутить регулятор. Если крутить дальше частота тарахтения чуть  возрастает. Даже если предусилитель на минимуме,   при вращении основного регулятора  громкости начинает тарахтеть. Если работает один триод такого нет при любой громкости. Играя на гитаре заметил, что низкие вообще не регулируются, средние слабо на частоте примерно 700-1000, высокие и брайт хорошо работают. Проверил еще раз по схеме ошибок вроде нет. Конденсаторы пересчитывать ?
    • От любой экономки 15-20 Ватт... - подойдётт"в лоб" и не надо ничего ремонтировать...  В крайнем случае  - в кругляше - балласте от экономки поменять конденсатор между нитями накала. На ... побольше ёмкости. 
    • ...от сука не пошла/о, пульсирует все, трансформатор выходной жужит  как старая шарманка завывая и похрюкивая пулсьсируя, ну очень ему не нравится что то. Выходные лампы бегают до 10-12мА мотая стрелку миллиамперметров, так же ФИ стрелки дёргаются в такт. ООС убрал, был перекос что одна выходная 20-25мА мотала стрелку, вторая пару мА было всего  и так же на ФИ с одним анодом чуть ли не мертвый был. При отключении  ООС как бы почти одинаково работатют плечи ФИ и выходных, но  дёрнается все жуть с частотой раза 2 в секунду стрелки пляшут.  Может ошибочно запаялся где, завра уже буду искать ошибки. НО правильно ли я припаял выходник? На А1 и А2 подал аноды ламп выходных, на В+ подал питание, эти контакты закорочены между собой на трансе. Оут-  припаял на массу. Пока Оут+ висит в воздухе, ООС убрал с нее. ОутГ не подключал и не знаю что это. А1-А2 = 233 Ом, между А1 (А2) и В+ половина,  т.е 116 и 117 Ом. Оут+ и Оут-  0.5 Ом. А между ОутГ и каждой Оут+ и Оут- по 0.6 Ом. Динамик не подключал.  Общее потребление канала пулсьсирует так же,  почти от 0 до 25мА приблизительно.     
    • не получается подправить код ( найти эти инклуды   #include <mega8.h>
      #include <delay.h>
               #include <>
      unsigned char blink = 0; void main(void)
      {
      PORTB=0x02;
      DDRB=0x01;
      while (1)
      if (PINB.1==1)
      { blink=1; }
      if (PINB.3==1)
      { blink=0; }
      if (blink) {PORTB.0=1;  }
      else { PORTB.0=0;  }
      }      
    • Вот расшифровка. Защита не включена.