Gosha Yolkin@yandex.ru

Extra-pic и его клоны

292 сообщения в этой теме

Вот решил собрать этот программатор своими силами,по схеме приведённой в описании набора Мастер-Кит,Всё собрал на макетке,и начал проверять по инструкции,также приведённой в описании (которое прикрепляю ниже).

В меню "Проверка программатора",когда ставиш галку "Вкл.Выход Данных",у меня появляется галка и на "Вход данных",Вопрос так и должно быть?

И есче когда замыкаеш линию "DATA" на общий провод,галки "Вход данных",не появляется,Вот у меня и появились сомнения в участке схемы обведённой красным на рисунке,может там ошибка?

3.JPG

exp10500.rar

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Быстрый заказ печатных плат

Полный цикл производства PCB по низким ценам!

  • x
    мм
Заказать Получить купон на $5.00
V_A_D    0

Товарищ наверное уже разобрался,но вдруг кому сгодится ,т.к. на сайте много полезного по наладке и проверке данного программатора :

http://www.5v.ru/extrapic.htm

У меня тоже проблемка,надеюсь добрые люди не оставят в беде :)

Суть:

Я программирую м/сх pic18F452-I/P

1)Открываю прошивку *.hex

2)Жму программировать и сразу же выскакивает сообщение об ошибке по адресу 000000h .

С прошивкой все нормально,т.к. ее повторяли многие - вариант отпадает

Стирать микросхему (правда она и так чистая,т.к. новая) программ-р не отказывается ,считывать тоже

Сам программатор проверен ,согласно методике http://www.5v.ru/exp-tst.htm и программа IC-PROG настроена согласно http://www.5v.ru/ic-prog.htm

Есть идеи?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
kazak    0

Я тоже собрал програматор с сайта 5V но не пашет зараза, как я понял если все правильно зделал при подключении должен загорется зеленый светодиод у меня не горит.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
V_A_D    0

У меня все разрешилось , а вы похоже светодиод не той полярностью включили

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Sergio    0

всем доброго времени суток. столкнулся с похожей проблемой. Собрал ЭкстраПик по схеме с http://www.5v.ru/extrapic.htm. Начал шить ПИК 16ф628А, появляется ошибка программирования по адресу 000h. начал тестировать и через методику http://www.5v.ru/exp-tst.htm и через WinPic. во втором случае пишет что аппаратная часть не обнаружена. А в первом случае проблема с каналом передачи данных. убрал КР1533ЛА3 и МАХ232, при проверке когда ставлю галку "Вкл.Выход Данных" у меня появляется галка и на "Вход данных" (нормально), а только вставляю их обратно - повторяется вся история. при этом горит зеленый светодиод (питание) и красный (напряжение программирования). что за глюк может быть. помогите!!!!!!!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
star    0

Всех приветствую.

Та-же проблема что и у Sergio, начал шить ПИК 16F628A, при проверке появляется ошибка по адресу 000h, горит зеленый светодиод (питание) и красный (напряжение программирования). Кабель самодельный (1-1, 2-2,..., 9-9), может из-за этого?

Sergio а у тебя получилось прошить, нашёл в чём дело было?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
technik08    0

была такая ересь, но блоком мастер-кит работем на общем компе и кто-то занял ком порт на прямую снял галочку и начил шить меги но пик 16f877a не захотел. собрал похожие ехстра (только на 40 ног) и опять не шьет. Кто шил обратил внимание продолжает гореть светодиод на U3 после. лично мне проше проверить все осцилографом. Что там должно быть на ножках?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
robot-5    5

всем доброго времени суток. столкнулся с похожей проблемой. Собрал ЭкстраПик по схеме с http://www.5v.ru/extrapic.htm. Начал шить ПИК 16ф628А, появляется ошибка программирования по адресу 000h. начал тестировать и через методику http://www.5v.ru/exp-tst.htm и через WinPic. во втором случае пишет что аппаратная часть не обнаружена. А в первом случае проблема с каналом передачи данных. убрал КР1533ЛА3 и МАХ232, при проверке когда ставлю галку "Вкл.Выход Данных" у меня появляется галка и на "Вход данных" (нормально), а только вставляю их обратно - повторяется вся история. при этом горит зеленый светодиод (питание) и красный (напряжение программирования). что за глюк может быть. помогите!!!!!!!!

а может микросхеме кирдык пришел. <_<

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
star    0

Если в настройках программатора ставлю инверсию тактирования, красный светодиод гаснет. При программировании 16ф628А, светодиод начинает моргать, т.е. что-то происходит. Проверить по методикам не могу, микросхемы запаяны, а выпаивать не хочу. Да и симптомы проявляются не только у меня, поэтому думаю что дело не в железе (программаторе).

Может всётаки в распиновке, я кабель сам собирал, подскажите на каком контакте, какие сигналы на выходе COM-порта комьютера.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
star    0

УРА, заработало. Действительно дело было в распиновке кабеля. Дело в том, что у меня на программаторе разъём такой-же как на мамке ("папа", небыло в магазыне "мам"), а кабель две "мамы". Так вот у "мамы" и у "папы" нумерация контактов разная (зеркальная). Я и собрал первый раз 1-1, 2-2, ...,9-9. Нужно 1-5, 2-4, 3-3, 4-2, 5-1, 6-9, 7-8, 8-7, 9-6. После исправления кабеля прошил контроллер с первого раза.

Может кому поможет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
lushas    0

Тот же прогрмаматор и та же проблема, только у меня как все подключил горит зеленый, красный вообще не горит, пробовал читать схему - вроде читает - прекращает гореть зеленый, но п IC prog везде нули. Пробовал зашить - зашивает - но при последующем чтении одни нули и контроллер не выполняет команды.

дело в кабеле? я припаивал кабель по цифрам. и что цифре на "вилке" отличаются от "розетки". надо убедиться.

А то это 3 мой програматор, и все не работали - не знаю по каким причинам...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
lushas    0

специально сьездил домой и проверил кабелек, - все верно. Теперь не знаю в чем проблема...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
sibiryak    0

Народ, помогите, плиз. Я собрал программатор по схеме EXTRA-PIC и у меня возникла такая проблемка. При подключении программатора к компу у меня начинает греться стабилизатор U1. При отключенном кабеле от компа при подаче питания ничего не греется. Выключаю, подключаю COMовский разъем начинает греться что аж не дотронешься до него и напря жение падает до 3,5 вольт. Я проверял распайку и нашел что кондюк С5 неправильно поставил и перепутал провода 7 и 8 на разъеме. Все исправил, но по прежнему стабилизатор греется. В чем может быть причина? И еще. Когда включаю в ic-prog тестирование программатора, то у меня в "Вход Данных" постоянно стоит галочка и не убираеться даже когда потсавишь галочку "Вкл. Выход Данных" или убираешь ее, пока не выключишь питание программатора.

Изменено пользователем sibiryak

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
sibiryak    0

Щас еще раз попробовал его включить без подключения комовского кабеля, тоже греется, но свои 5 вольт дает

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
cam    1

Может какие нибудь ячейки ла3 - битые, вот и потребляет лишнего. Мах 232 и ла3 тестером по уровням легко проверить. Хоть добейся, чтобы не грелось ничего и логика правильно звонилась.

А ком порт целый?, как он может так греться, абсурд, там нет таких токов. Да, и печатку откуда брал?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
sibiryak    0

ком-порт не греется. греется стабилизатор. Вроде перестало греться, я поменял max232. Видно после первой моей ошибки по распайке микруха вышла из строя.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
cam    1

Собрал программатор Extra-Pic, работае нормально, но у меня вопрос. Почему при ЧТЕНИИ например pic 16F84, светодиод горит, указывая на подучу 13в программирования.

При программировании тоже горит, ну здесь понятно. хотя всё пишет и читает. Вопрос?, должно ли поступать напряжение с порта, вывод 3- Тх, во время чтения - оно и открывает ключь на 13 вольт.

Чувствую дело в проге icprog106A. При прошивки ЕЕPROM 24Cxx диод 13в не светится, но там и нет Vpp. Может настройки какие, хотя всё перепробовал. Подскажите кто знает, как правильно должно быть?

Спасибо

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
LuckyLex    0

Собрал extrapic, вместо кт3102 поставил ksp2222

при подаче питания зелынй светик горит, красный нет

когда просто подсоединяю com шнур загорается красный светик, т.е. подаётся питалово MLCR

при тесте через испрог при нажатии галочки выключается, при отжатии опять включается MLCR

не пойму почему так, подскажите пожалуйста

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
kpeoji    0

Я тоже мучаюсь с этой проблемой но я поставил 3102. И проблему решил просто. В самой программе поставил инвертирование Vpp или mclr.

*********************************************************************

Мой вопрос))

*********************************************************************

Сначало долго мучался и не мог понять почему у меня в спокойном состоянии на vpp 13в. Нашел как тестить программатор и все понял. Что дабы избежать ошибки можно просто программно инвертировать Vpp. Но согласитесь это не выход. Вот хочу узнать есть ли возможность аппаратно перевернуть vpp. схему брал вот отсюда схема. А печатку брал у Александра Любаева. Единственное изменение. Это использование электролита по питанию 470мкф. которое должно ставится с внутренним источником питания. Я использую внешний но на момент сборки были только 470мкф. Так же вместо транзисторов которые он использовал я поставил кт502е и кт3102. Так же по причине нахождения таковых в момент сборки. Программатор шьет отлично но... Vpp, некрасиво просто. И еще такой вопрос для чего нужен желтый диод, который стоит рядом с джампером?. Никак не могу понять. Джампер как я понял переключает программатор в работу с ПИК и АВР. Но место джампера не влияет на работу программатора для пик. Проверено. Тоже не понятно. Спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
LuckyLex    0

У меня давно решилась проблема. Неправильно впаял транзистор и второе, шнур продавцы суки подсунули нульмодемный.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
IMXO    1 056

Джампер как я понял переключает программатор в работу с ПИК и АВР. Но место джампера не влияет на работу программатора для пик. Проверено. Тоже не понятно.

вы не правы положение джампера влияет на программирование пиков

в старых пиках для входа в реж прог. сначала подается Vcc после Vpp

в новых содержащих встроенный генератор сначала подается Vpp после Vcc

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
my504    155

в старых пиках для входа в реж прог. сначала подается Vcc после Vpp

в новых содержащих встроенный генератор сначала подается Vpp после Vcc

Это в каких новых и каких старых?

И какой такой встроенный генератор?

Системный тактовый генератор в программировании никакого участия не принимает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
IMXO    1 056

старые это типа 16f84,84a

новые типа 16F631 отличия в режимах: ссылка

Изменено пользователем IMXO

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
kpeoji    0

а как мне перевернуть vpp никто не знает?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
IMXO    1 056

а как мне перевернуть vpp никто не знает?

знаем еще один транзистор с резистором добавь

токо не пойму зачем эти танцы с бубном

Изменено пользователем IMXO

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас