-=FISHER=-

Найдите пожалуйста ошибку в подключении мофетов

18 сообщений в этой теме

Добрый день!

Укажите пожалуйста, где я ошибся в данном включении двух мосфетов, один P-канал - управляет нагрузкой, второй N-канал - управляет P-каналом и управляется с МК (НО в данный момент МК не подключен к схеме). Проблема в том, что P-канальный транзистор всегда открыт у меня, хотя N-канал при этом закрыт. Напряжения Vgs отражены на схеме. Третий день бьюсь над этим, проверил подключение много раз, все верно. В Протеусе работает, а на практике нет... просьба помочь и объяснить по возможности подробно.

mosfet.jpg.a74614b76670cca604203912848f503b.jpg

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Напряжение на стоке n-канального  посмотрите . На закрытом должно быть 12V , если оба транзистора исправны . 

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
6 минут назад, colorad сказал:

Напряжение на стоке n-канального  посмотрите .

Относительно чего посмотреть?

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот фрагмент реально работающей схемы от ESR_LCFv3 from miron63 - сравни со своей :)

 

123456.jpg

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

16 минут назад, colorad сказал:

"0" конечно 

А там 0 вольт...

Изменено пользователем -=FISHER=-
0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Значит он открыт или пробит . Закрыть можно замыканием затвора на "0" . Если не помогает смотрите монтаж или меняйте .

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
43 минуты назад, colorad сказал:

Значит он открыт или пробит . 

Если он пробит, то выпаяв его должно быть КЗ между стоком и истоком? А если он всегда открыт, то на плате должно быть КЗ между затвором и истоком?

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Может быть повышенная утечка затвора. Мне такие встречались. Тогда и К.З. не будет.

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
2 минуты назад, colorad сказал:

Звоните,  выпаивайте , смотрите 

Выпаял, звонится очень странно сток-исток падение напряжения (или что показывает тестер в режиме прозвонки) 478, а на таком же новом 500. Впаял такой же новый, нагрузка перестала включаться...Но КЗ так и не показал, странно

1 минуту назад, Falconist сказал:

Тогда и К.З. не будет.

Вот наверное тот самый случай...

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

http://forum.cxem.net/index.php?/topic/13268-простые-схемы-для-лаборатории-радиолюбителя/&do=findComment&comment=414343

П.5 - методика "прозвонки" полевиков. Точно так же будет работать и со стрелочным тестером. С цифровым не пробовал, но думаю, что тоже пойдет на режиме измерения сопротивлений.

1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В общем Вы наверное скажете этой первый класс или типа того, потому что спалив около 10 мосфетов AO3400 я понял, что было причинами.

Во-первых: плата была плохо промыта и через флюс где-то сидел коротыш. Промыл и нагрузка перестала сама по себе включаться.

Во-вторых: Потом было замечено что когда AO3400 впаян в плату, я подпаивал к его затвору провод, который должен в последствии подавать те самые +5 вольт на его затвор имитируя включение лог.1 на МК. И по всей видимости (паяю ОБЫЧНЫМ паяльником, не паяльной станцией) статикой или какой то ещё помехой от электро сети я каждый раз пробивал этот мосфет! Поменял последовательность, сначала впаяв провод на затвор, а потом уже сам мосфет проблема была решена!

И, наверное уже крайний вопрос, теперь при подачи +12В на схему замечаю кратковрененное (меньше секунды) вспыхваиние светодиодов нагрузки. А уже потом подавая +5В на затвор AO3400 нагрузка включается незамедлительно, однако когда я снимаю +5В с завтора AO3400 то нагрузка как будто отключается не мгновенно, а с задержкой, меньше секунды, примерно такой же по длительности как и моргание при включении.

В чем причина такого эффекта?

Вот полная схема (в качестве нагрузки выступает светодиодный драйвер на PT4115):

mosfet1.jpg.ffbd7701ed76089f107b8615995ee7a5.jpg

Изменено пользователем -=FISHER=-
0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

1 час назад, -=FISHER=- сказал:

нагрузка как будто отключается не мгновенно, а с задержкой

С4 , наверное , попробуйте его уменьшить до 1uF

 

 

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Можно поставить копеечный оптрон вместо первого полевика - решится сразу две проблемы - с затвором, и помехозащищенностью. Появится гальваноразвязка МК и нагрузки.

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Кроме того, pt4115 можно отключать по входу DIM, вообще без этих полевиков, тем  же оптроном.

Изменено пользователем Vovk Z
0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
5 часов назад, -=FISHER=- сказал:

по всей видимости (паяю ОБЫЧНЫМ паяльником, не паяльной станцией) статикой или какой то ещё помехой от электро сети я каждый раз пробивал этот мосфет! 

чушь ... это все срань на ПП, которую ты развел, а не паяльники. более того - нужно ПРАВИЛЬНО проверять, как тебе и сказали, полевики, особенно "лоджик-левел" и уметь их не только "открывать", но и "закрывать" тестером, банально поменяв полярность щупов на З-И (G-S).

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
2 часа назад, KRAB сказал:

чушь ... это все срань на ПП. более того - нужно ПРАВИЛЬНО проверять, как тебе и сказали, полевики, особенно "лоджик-левел"

Я тоже думал что чушь. Никакой срани не было. было немного пригоревшего флюса. Этот мофет не лоджик левел.

7 часов назад, colorad сказал:

С4 , наверное , попробуйте его уменьшить

Вряд ли получится уменьшить, так как эта ёмкость из даташита. Есть ещё несколько драйверов таких же (сам собирал). Такого эффекта нигде нет. Больше меня волнует именно моргание при включении. Из-за чего может такой эффект быть? Ведь мосфеты закрыты изначально....

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ваша публикация должна быть проверена модератором

B
Вы не авторизованы. Если у вас есть аккаунт, пожалуйста, войдите.
Ответить в тему...

×   Вы вставили отформатированное содержимое.   Восстановить форматирование

  Разрешено не более 75 смайлов.

×   Ваша ссылка была автоматически встроена.   Отобразить как ссылку

×   Ваш предыдущий контент был востановлен.   Очистить редактор

Загрузка...

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу