6 сообщений в этой теме

D_E_G_    0

В общем достался мне вольт ампер метр с маркировкой на плате "dsn-vc288" с упаковки был непропай ОУ LM358, он включился и нормально измеряет напряжение, но ток показывал всегда 2А (нагрузка - вентилятор с компьютерного БП с потреблением 200мА) даже при отключенном проводе измерения тока. После того как я пропаял выводы ОУ вместо 2А прибор стал показывать 5А и когда кручу калибровочный резистор показания регулируются в приделах 1 ампера (т.е . от 5 до 6А). Походил по форумах и ничего для себя не выяснил. Говорят что на выходных выводах №2 и №8 должно быть напряжение 100-200мВ, у меня только на 8 выводе 230мВ. Может кто что подскажет? Все фото тут не влезут, по этому оставлю ссылку на хостинг с изображениями: фото платы , показания с выводов LM358

20180621_102410_HDR.jpg

20180621_102428_HDR.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
IMXO    1 324
21 минуту назад, D_E_G_ сказал:

Говорят что на выходных выводах №2 и №8 должно быть напряжение 100-200мВ, у меня только на 8 выводе 230мВ. Может кто что подскажет?

выв. 8 у LM358  вывод +питания.... о каких 230мВ речь?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
motoandrey14    584
1 час назад, D_E_G_ сказал:

у меня только на 8 выводе 230мВ.

Странно, по фото "на осциллографе" у тебя нормальные 3.3В... Определись!

5 и 6 входы идут к шунту. 7 (выход) идёт на потенциометр и после в контроллер.

В контроллере есть установка нуля замыканием определённых пинов. Если ток примерно-измеряет, то установи ноль! (откалибруй контроллер), а после уже отрегулируй потенциометром точность показаний! 

 

Вот, замкни "I_ADJ_ZERO" (установка нуля) и включи - должно откалиброваться в ноль. Возможно, придётся это делать в несколько этапов, так как за раз 5 ампер не прыгнет, можно попробовать подать "минус 5 ампер", один ампер или половину скалибрует, и так потихоньку несколько раз, пока до нуля не выйдешь.DSN-VC288-terminals-1024x1024.jpg

Изменено пользователем motoandrey14
  • Одобряю 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
D_E_G_    0
1 час назад, IMXO сказал:

выв. 8 у LM358  вывод +питания.... о каких 230мВ речь?

небольшая опечатка - на 2 и 7 выводе должно быть 100-200мВ. на 8 выводе у меня 3.3в

36 минут назад, motoandrey14 сказал:

Странно, по фото "на осциллографе" у тебя нормальные 3.3В... Определись!

Все верно, на 8 выводе 3.3В, в теме небольшая опечатка - на 2 и 7 выводе должно быть 100-200мВ. 

 

37 минут назад, motoandrey14 сказал:

Вот, замкни "I_ADJ_ZERO" (установка нуля) и включи

Пробовал - когда я замыкаю "I_ADJ_ZERO" хоть в включенном, хоть в выключенном состоянии весь индикатор тухнет и горит только 1 сегмент (выделил на фото)

20180621_102428_HDR — копия.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
motoandrey14    584

@D_E_G_ Эту процедуру сделал перед этим? Подавал ампер 5-6 на шунт в обратном включении?

1 час назад, motoandrey14 сказал:

Вот, замкни "I_ADJ_ZERO" (установка нуля) и включи - должно откалиброваться в ноль. Возможно, придётся это делать в несколько этапов, так как за раз 5 ампер не прыгнет(ошибку напишет или ничего не откалибрует), можно попробовать подать "минус 5 ампер", один ампер или половину скалибрует, и так потихоньку несколько раз, пока до нуля не выйдешь.

Если нет, то ты читать вообще умеешь, что тебе пишут? Или ещё один писатель, но не читатель?

27 минут назад, D_E_G_ сказал:

на 2 и 7 выводе должно быть 100-200мВ.

1, 2 и 3 выводы не задействованы. То, что там должно быть, никого, даже тебя, не должно волновать от слова СОВСЕМ.

Написал же конкретно, что 5 и 6 входы ОУ идут к шунту.(напряжение близко к нулю) 7 - выход ОУ, идёт на потенциометр и после в контроллер. Напряжение на шунте должно изменять напряжение на 7 ноге. Это главное. По сути 7 вывод LM358 и есть показания тока. Сейчас у тебя там 200мВ, по показаниям это 5А. Тебе нужно сделать так, что бы эти 200мВ были по показаниям "0". Сделать это можно только выставив "0" (I_ADJ_"0"). Так как он уже откалиброван в +5А, то такую величину он сразу тебе не выкалибрует, тебе нужно искуственно подать -5А, и попытаться откалибровать, затем подать -4А, и снова откалибровать, до тех пор, пока в ноль не выйдешь.

Изменено пользователем motoandrey14

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
D_E_G_    0
10 минут назад, motoandrey14 сказал:

Эту процедуру сделал перед этим? Подавал ампер 5-6 на шунт в обратном включении?

Не успел, продавец вышел на связь, и попросил вернуть, для замены. Спасибо Вам большое что пытались мне помочь) 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас