Sign in to follow this  
Guest karpukopf

проблема с STM32&HAL&IAR&LCD nokia 1202

2 posts in this topic

Guest karpukopf   
Guest karpukopf

Добрый день! Наступаю на какие то стандартные грабли с STM32&HAL&IAR но на какие конкретно понять не могу. МК - STM32l432, подключаю дисплей nokia 1202 по SPI. Используя битбэндинг дисплей заводится без проблем, используя аппаратный SPI - только через отладчик, после перезагрузки не работает, при этом основной алгоритм выполняется, видно по светодиодам. Сигналы на SCK и MOSI есть (осциллографа под рукой сейчас нет, чё то мультиметром намерил). Всевозможных задержек понаставил, частоту менял, варианты настройки SPI на всякий случай перепробовал наверное все уже. В чём может быть дело? Ещё важный нюанс - отладчиком программа запускается только с опцией IAR ST-LINK reset: software, иначе так же, светодиоды моргают, дисплей не работает.

Share this post


Link to post
Share on other sites
optima    235

Возможно какую нибудь ногу забыл притянуть к необходимому уровню. Проверь boot0

 

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this