Alks_D

At89S51 Ведет Себя Некорректно

11 сообщений в этой теме

Alks_D    0

Доброго времени суток!

Проблема возникла с AT89S51, вернее с его правильным включением в схему.

Подключаю его так 40 - питание +5в, 20 земля, сделал автоматический Reset при включении питания ( конденсатор на 10мк к 9 ноге (RST) и от 9 ноги на землю резистор на 150 кил), также для того чтобы мк выполнял прогу из внутренней памяти подключил ногу 31 (EA) через резистор 1к к питанию. Кварц на 12 МГц на землю через кондеры на 33 пик.

Написал простую прогу на асме, сбрасывает все порты в ноль, а потом дергает пин 0 порта 1 с частотой 40 кГц. Прога проверена в симуляторе. Программировал "Тритоном". Верификация проходит успешно.

Контроллер ведет себя так ( проверял осциллографом), на порт 0 на пин 0 и 1 выдаются имульсы 5 в с частотой около 2 МГц...все остальные пины 0 порта в нуле..сигнал PSEN есть 2МГЦ имульсы. Все остальные порты в единице.

Проверил напряжение питания 5в, EA 5в, ресет 0, при включении полсекунды примерно уровень лог 1 на ресете.

Есть второй точно такой же AT89S51 незапрограммированный, ведет себя также.

Складывается впечатление что МК пытается читать программу из внешней памяти (т.к. при этом он задействует порт 0 и частично порт 2).

Вопрос: может что не так в номиналах элементов или вообще не так подключаю, либо нужно установить какие то параметры в программе?

P.S. Если непонятно описал схему включения, могу нарисовать и прикрепить сюда.

Заранее спасибо :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Быстрый заказ печатных плат

Полный цикл производства PCB по низким ценам!

  • x
    мм
Заказать Получить купон на $5.00
o_l_e_g    1 617

PSEN- сигнал инверсный. В каком сейчас состоянии.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Alks_D    0

PSEN- сигнал инверсный. В каком сейчас состоянии.

смысле? на него разве чтото нужно подавать? на осцилографе наблюдал импульсы около 2 МГц..быть может вы имели ввиду инверсный относительно кварца...

проблема в том, что МК по ходу не хочет работать с программой из внутренней памяти, а пытается найти внешнюю...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
o_l_e_g    1 617

на него разве чтото нужно подавать?

Запутал меня со стобом, не PSEN, а EA :)

Куда, к нулю или к денице он подключен определяет с какой памятью работает МК Так что смотри ЕА

External Access Enable. EA must be strapped to GND in order to enable the device to fetch

code from external program memory locations starting at 0000H up to FFFFH. Note, however,

that if lock bit 1 is programmed, EA will be internally latched on reset.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Alks_D    0

так я написал, что EA подключен через резистор на 1кОм к Vcc...проверял вольтметром есть там +5в...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
o_l_e_g    1 617

есть там +5в...

Странно.

Может включены прерывания? и с какого адреса начинается программа?

В нулевом адресе есть 02н? и дальше адрес примерно 30?

ЗЫ исходник и хекс, можно посмотреть?

Изменено пользователем o_l_e_g

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Alks_D    0

код, листинг, хекс..прикрепил в архиве

test2.zip

Изменено пользователем Alks_D

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
o_l_e_g    1 617

Ошибка в том, что в программе задействовано поле с векторами прерываний. Подправил пробуй.

org 0h
;************ 
jmp 30h
org 30h
;************ 
mov A,#0h
mov P0,A
mov P1, A
mov P2, A
mov P3, A
begin:
mov A,#00000001b
mov P1,A
nop
nop
nop
nop
nop
nop
nop
nop
nop
nop
nop
nop
nop
nop
nop
mov A,#0h
mov P1,A
nop
nop
nop
nop
nop
nop
nop
nop
nop
nop
nop
nop
nop
nop
nop
jmp begin

END

Да и в программе, много "лишних движений!". Пересылать можно минуя А. Инвертировать, можно непосредственно один бит. Как первая учебная, нормально!.

Изменено пользователем o_l_e_g

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Alks_D    0

залил программку, происходит тоже самое. Заливал хекс также из темы форума "Начинаем Работать С 51-Ми Контроллерами" (про мигание светодиодами), контроллер ведет себя точно также. Куда копать? :(

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
o_l_e_g    1 617

Попробуй запретить все прерывания, бит ЕА...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Alks_D    0

попробовал, ничего не изменилось. интересно, что же не так...

прикрепил исходник и хекс...

TEST51.rar

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас