Jump to content

Kravtcov Ivan

Members
  • Content Count

    4
  • Joined

  • Last visited

Posts posted by Kravtcov Ivan


  1. Всем доброго времени суток.

    В multisim 14.1 создал симуляцию схемы от Analog Devices CN-0350. Схема работает, создал ее в реальности, работает. Но есть одно НО она на выходе выдает сигнал всегда с постоянной амплитудой т.е. на текущем этапе годится разве как частотомер, но по описанию из даташита на выходе я должен получать Vo2 = Vhref + (1+R7/R8)*(Sa/C2)*da, где Vhref = 1.25V (опорка HREF на схеме, в реальности все 1 в 1), Sa - коэффициент чувствительности по заряду для пьезоэлемента выраженный в ед. разности потенциалов, da - ускорение. В литературе пишут как U=Q/C, в данном случае C2, а Q = d33ma=d33F, где d33 - чувствительность датчика по оси 3, m - инерционная масса на поверхности кристалла, a - ускорение, F - сила. В моем случае m = 5гр, d33 = 320пКл/Н, что в моем случае получается Sa = (320*10^-12Кл/Н)*0.005кг*9,81м/с2 = 15,7пКл/g. Но по уточненным данным m считается как mэфф = mи + 0,5mпэ, где mпэ = 3,5гр, тогда Sa = 22пКл/g. В литературе по усилителям заряда для пьезокерамических изделий U = Q/C2, тогда (22пКл/g)/1nF = 22мВ/g. Следуя дальше получается на выходе 1го ОУ (U2A) на выходе Vhref-+22mV в зависимости от направления силы на ПЭ, а следующий усилитель настраивается по коэффициенту усиления через R8 в зависимости от характеристик АЦП, в данном случае диапазон 1,25В+-1,15В т.е. запас по ускорениям +-50g. Но в реальности я не получаю на выходе зависимости выходного напряжения от силы, на выходе либо 2,4В либо 0,1В и никакой плавности, а нужен на выходе синус или импульсы(смотря какое усилие на ПЭ). Помогите найти ошибку). По описанию все должно работать, а на самом деле нет. Кстати в симуляторе работает, если на вход поставить источник тока и это логично т.к. пьезоэлемент является источником тока, но на реальном устройстве при воздействии на элемент я вижу только изменение ширины выходных импульсов т.е. прямоугольный сигнал. Может дело в наводках? На выходе 50Гц. Может устройство нужно питать от АКБ? Т.к. у меня много материала на эту тему, то в одном сообщении не уложусь, дополнительную информацию предоставлю по ходу беседы.

    схема 1.jpg


  2. Доброго всем времени суток.

    Столкнулся с проблемой:

    Имеется в наличии импульсный блок питания с однополупериодным выпрямителем, обратная связь на TL431. Настроил выходное напряжение с 12В на 8,4В.  Ко всему к этому добавил китайский цифровой амперметр-вольтметр. Ток с + выхода БП ограничен резистором 12,5 Ом. Получилось некоторое ПОДОБИЕ зарядного устройства с ограничением по току 672 мА. Если замкнуть клеммы этого БП, то на амперметре видно, что ток в цепи примерно 672 мА, на мультиметре так же. НО, если к такому БП подцепить плату  БМС с двумя АКБ 18650(последовательно т.е. 7,4-8,4В), то ток в цепи не более 100мА. Эта же плата БМС с двумя АКБ 18650 на БП KORAD 3005D с выставленным напряжением 7,5 В и ограничением по току 600 мА, потребляет ровно 600 мА т.е. она способна и больше потребить, но ограничил на БП. Не понимаю, почему блок питания на 8,4 В отказывается заряжать АКБ. Покопавшись в гугле нашел информацию о том, что АКБ может разряжаться в БП и необходим диод с анодом на минус, а катодом на минус БМС. Еще предполагаю, что TL431 при подключении внешнего источника питания начинает работать не так как было задумано т.е. снижает напряжение с выхода импульсного трансформатора до значения разницы между напряжением АКБ и БП (по крайней мере так сходится по значению тока в 100 мА т.к. АКБ заряжен до 7В, а на БП 8,4В ). Надеюсь получилось объяснить.  

×
×
  • Create New...