Jump to content

zoom-0

Members
  • Content Count

    244
  • Joined

  • Last visited

Everything posted by zoom-0

  1. Спасибо, пошел в гугловский читальный зал пс/ а как в "репу" плюсануть ? только не отправляйте в гугл и в правила форума
  2. То есть если число в десятичной ( например больше 32000) мы приписываем L а вторая L зачем ? long long ( long2 ). И как образуется само число ? в разных скетчах оно разное. например : const uint64_t pipes[6] = { 0xF0F0F0F0D2LL, 0xF0F0F0F0E1LL, 0xF0F0F0F0E2LL, 0xF0F0F0F0E3LL, 0xF0F0F0F0E4LL, 0xF0F0F0F0E5LL }; на основе чего оно образуется ? Посмотрел внутри библиотеку, но не увидел там например "min max". Где-нибудь есть полное описание библиотеки rf24 / nrf24l01 ? все что есть в интернете, это просто примеры , а описания нифига нет
  3. Товарищи, такой вопрос : насколько я понял , приставка 0х означает что далее следует 16-ричное число. ( например 0х1F , где 1F и есть данное число.), но например в скетче модуля NRF24 есть строка : "radio.openWritingPipe(0x0123456789LL); // Задаем идентификатором 0x0123456789LL для передачи данных" вопрос в том почему там есть буква "L", если максимально допустимая F, и на каком основании ( из каких соображений) вообще задается этот идентификатор ? ps- скетч передачи данных для ARDUINO
  4. Почти даром . Ещё есть рэс-9, рэс-6, рэс-22 и РЭС 54.
  5. Всем доброго времени. Нужен мощный н-мост для управления двигателем от печки ваз2101-07 ( на нем надпись 20 Вт). Управление будет от Ардуино по ШИМ далее н-мост и мотор. Время работы долговременное, плюс на мотор будет нагрузка ( шкив с ремнем ). Вопрос: у меня есть советские кт818-819 в корпусе то220. С хорошими радиаторами потянут они такой мотор ? Если нет, то какие потянут?
  6. Добавлю, кому интересно, по поводу ошибки пина и балобольства аппарата по секторам. Раньше бывало выдавал при включении ошибку pin6 или 9 ... Не помню. Разобрал, потряс, подул - собрал, все хорошо. Так же иногда была самопроизвольная постоянная пляска сигнала по всем секторам ( в поле). Перенастроил все профили и настройки. Заменил АКБ ( питаю от двух 18650, на дисплее показывает 18 вольт :), видимо делитель умер, раньше честно показывал). После ПОЛНОЙ перенастройки (стёр все профили и создал новые) все работает ровно. Использую прибор очень редко. Плату покупал уже в сборе и прошитую и катушку собранную.
  7. спасибо за ответ, ( ничЁсе скока циферок в коде... каждое деление прописали...) но сделал немного по другому, у кого-то из скетча дернул кусок : if (recieved_data[0] >=128 && recieved_data[0] <=189)data = recieved_data[0], bspeed = map(data, 189, 128, 255, -255), backward(bspeed); if (recieved_data[0] >=201 && recieved_data[0] <=255)data = recieved_data[0], fspeed = map(data, 255, 201, 255, -255), forward(fspeed); if (recieved_data[0] >190 && recieved_data[0] <200)data = recieved_data[0], stop(); тоже поставил н-мост (но схема другая, тоже на 6 транзюках) и вот тут началось... спаял... транзисторы сами немного открываются , двигатель покряхтывает, потом начинает крутиться , и все это при условии, что я никаких команд ему не даю. спаял три моста, менял резисторы. В разных мостах делал разные транзисторы. (кт816-817 / 805-837 / 972-973 ) результат всегда один - транзисторы открываются без сигнала и одна пара жутко греется. выпаял все из платы - собрал на макетке ( что бы легче резисторы подбирать ), а подбирать ничего не нужно ! на макетке работает идеально ! спаял снова на другой плате... и опять греется и сами открываются. плату помыл. не помогло. Плюнул на эстетичность, собрал опять , но уже на маленькой макетке, и макетку запихал в машину :). все работает.
  8. Всем здравствуйте. Народ, подскажите в таком деле. Как заставить один мотор при управлении джойстиком изменять мощность и направление? Вся суть такая: собрал пульт на ардуино с передатчиком nrf24l01 ,на пульте есть два джойстика - один джойстик управляет двумя серво по осям, на втором джойстике ось Х сервомотор поворота передних колес , а ось Y это будет основной мотор, вот его не могу заставить крутиться как нужно. Это будет радиоуправляемая машина. То есть от джойстика она должна ехать с регулировкой мощности (скорости ) вперед и назад от центральной точки джойстика. Пробовал прописать : ...(joyY), 0, 1023, -255, 255)... но в этом случае по шим ключ-мосфет работает только от 0 в сторону +255 и то как-то не корректно. подскажите как правильно написать : если джойстик в среднем потожении (+- 5 градусов) мотор выключен, если в сторону +255 едем вперед, если в сторону -255 едем назад. Как правильно прописать команду если ,к примеру, я хочу вывести значения движения вперед на 6pin (шим) , а значения движения назад на 5pin (шим). Два этих выхода я подкину к драйверу двигателя. { if (digitalRead(joyY), 500, 520, 0, 0) digitalWrite(6,LOW) digitalWrite(5,LOW) if (digitalRead(joyY), 521, 1023, 0, 255) digitalWrite(6,0, 255) digitalWrite(5,LOW) if (digitalRead(joyY), 0, 499,0, 255) digitalWrite(6,LOW) digitalWrite(5,0, 255) } вот так верно будет ?
  9. Народ, день добрый, кто в теме, подскажите. у какого осцилла меньше погрешность , понятно что оба не айс, просто нужен ответ у ардуиновского (отсюда) или DSO150 (вот такой)
  10. Проблему решил. ( по детски ), разобрал. включил , он написал ошибку пин#6 или пин#9, я думаю непропай где-то наверное. Погрел феном без фанатизма. Собрал все назад. Все работает. Надеюсь надолго. В прошлом году когда он так бегал по секторам он тоже потом ошибку какого-то пина выдавал, но потом сам заработал. Я думаю может еще от того что я корпус почти герметичным старался сделать ( от дождя , мокрой травы...) но гнезда все открыты. Возможно влага попала, но не вышла, и осела где-то мелкой окисью.
  11. доброго времени, народ, подскажите в таком вопросе : работал квазар исправно и хорошо года два. Однажды за это время при включении начал плясать сигнал по всем секторам, то там , то сям, издавая музыкальную какофонию. Выключил... через час включил, все хорошо. А недавно включил и опять сигнал бегает по секторам попискивая везде от железа до меди... Все это происходит в поле... чистом поле. При обнаружении металлов пищит как положено, но эти постоянные ложняки идут бесперебойно. Прибор покупной. Осциллографа у меня нет. Можно при помощи тестера починить? На что обратить внимание? Прибор сбросил, отстроил, перестроил... ложняки... Или просто катушка умерла ? ( при отключении катушки в приборе тишина )
  12. начал менять емкости. Заменил пару, потом обнаружил на одном кондерчике ( 1мкф-50в ) "холодную пайку", пропаял. Все работает. Подключил строительный фен ( 2000 Вт ) на слабом режиме, все отлично. Всем спасибо за помощь ! ( где в репу плюсануть не найду )
  13. Что бы сделать Правильные замеры нужно знать где мерить :), Завтра заменю емкости, если не поможет составлю карту напряжений выводов микросхемы и транзисторов в режиме работы и когда блокируется. ( указанное место проверю тоже ).
  14. то, что я выложил это практически вся схема. Еще трансформатор и вольтметр... и усё
  15. да, там видимо нагрев стабилитрона, я там первым делом пропаял контакт стабилитрона ( диода ? ) и резистор рядом. Эффекта не последовало. Завтра тогда просто поменяю все емкости. И если найду на нем маркировку, стабилитрон.
  16. Да нет, вы не так видимо поняли. Он уходит ,как я понял, в защиту от "козы" и клацает реле. А дело было так... Работал он очень хорошо 8-9 лет ! вчера вырубился ( я думаю ушел в защиту ), отключили, подождали, включили. Сутки поработал и вырубился опять. Сейчас работает если нагрузка очень маленькая - зарядка телефона, блок питания на 30 вт. и тп. , а если подключить что-то мощнее 100-150 Ватт , то он вырубается. Стрелка индикатора падает на ноль и релюшка клацает постоянно (0,8-1,5 сек ), во время клацанья релюшки стрелка пытается дернуться , но возвращается на ноль. Поэтому я и решил, что просто он любую нагрузку выше 100-150 Ватт считает перегрузом и уходит в защиту. ( мощность котла по паспорту 120-150 Вт ) ЗЫ. котел газовый. там нагрузки-то пара двигателей и электро-клапан. Сейчас поставили временно другой стабилизатор но 240 Ватт. Работает. Котел не виноват
  17. Товарищи, такая проблемка нарисовалась. Есть у меня стабилизатор. через него подключен котел. А сейчас стабилизатор вырубается под нагрузкой . Стабилизатор СПНБ-1000-Р схема вроде простенькая, но в и-нете не нашел. Кто знает подобные схемы , какая обвязка отвечает за защиту и выключение при перегрузке ? извиняюсь, не нашел где под спойлер спрятать...
  18. нашел схему, по которой собирал.
  19. Обвязка почти по даташиту и схемам выше. Какие выводы микросхемы отвечают за ток? На каких ногах перебрать (изменить) обвязку? При нагрузке выше двух ампер , не важно как включать, сначала нагрузку потом БП или наоборот. Всегда блокируется.
  20. товарищи, такая проблема: собрал регулируемый блок питания из АТХ на 6105, все работает, но при нагрузке выше двух ампер уходит в режим защиты. подскажите в какой цепи подкрутить, что бы увеличить максимальный ток срабатывания ?
  21. Всем доброго времени. Снова возник вопрос. Ситуация такая : все работает, напряжение регулируется (4,85....17v) тянет 1А, 1,5А (диодная лента).но при включении ,допустим автомагнитолы (без акустики ) не тянет. блокируется как от КЗ на выходе. в то же время слабенький БП тянет магнитолу, правда с просадкой в 2V. Магнитола абсолютно рабочая, стоИт в машине. вопрос в том почему не тянет ?? и как исправить ?
  22. всем снова здравствуйте. Отпаял все "обвесное" вокруг микросхемы 6105. По даташиту и схемам предложенным выше сделал новую обвязку. (деталей стало меньше и совсем другие =)), теперь при включении ИБП лампа мигает (причем яркость зависит от поворота движка резистора регулировки выходного напряжения от 17 ноги), и при отключении от сети через 2 сек. снова мигает. То есть вроде как включается, конденсатор перенасыщается (или наоборот, набирает и блокирует шим), и при выключении на "том конденсаторе" напряжение падает и она успевает мигнуть еще разок. Подскажите какая часть обвязки за такое может отвечать ? PS/ еще момент... включил, оставил посмотреть вдруг дымок откуда пойдет =), лампа на выходе вспыхивает каждые три секунды. (лампа от авто 12в \ 1вт), и после отключения от сети через три секунды мигает последний раз. ЗЗЗЫЫ___ Все, разобрался ! я после стабилитрона (дежурка 12v ст.) поставил для выравнивания кондерчик 10мкX25в. отпаял его . и о чудо !!! все работает !!! теперь буду окультуривать внешний вид ))
  23. товарищи, переделывал бп ,микруха 6105, на регулируемый (1-12в). собрал. на выход повесил лампу 12в1вт, при включении лампа на выходе мигнет и тишина... подскажите в какой цепи искать проблему. (+5 есть, +12ст тоже есть. при их отключении от микрухи результат тот же =( ps/ есть ли карта напряжений для микрухи? (только не для осциллографа)
  24. Узнайте пожалуйста, если цена устроит, я могу и сам забрать в Москве.
×
×
  • Create New...