Jump to content
tsf54

Эа-2012 Двойка

Recommended Posts

Поставил ток уна 15ма   с5   10пкф.   картинка на 25кгц  дальше полки синуса. Пробую ток уна 10ма  

 

P70201-144757[1].jpg

Share this post


Link to post
Share on other sites

Руководство для разработчика приложений на базе STM32WB55

Представив двухъядерные беспроводные микроконтроллеры STM32WB для IoT-приложений, компания STMicroelectronics предлагает разработчикам экосистему, включающую в себя отладочные платы, примеры кода для микроконтроллера, готовое ПО всех уровней и большой массив документации.

Читать статью

Оставьте ток покоя УНа в покое. :) Какая емкость Миллера в УНе? Если по дефолту, то увеличьте до 20-22 пФ. С5 тоже не трогайте, его надо чуть по другому крутить.

Edited by finn32

Share this post


Link to post
Share on other sites

При токе УН ниже 18мА резко увеличиваются нелинейные искажения, особенно на малой мощности. И причем здесь ток УНа до бяки на максимальной мощности. усилитель просто не настроен. Искать причину надо, а не ток УНа он здесь не причем.

Share this post


Link to post
Share on other sites
                     

Контроль в спящем режиме: повышение КПД батарейного питания с помощью DC/DC MAX17225 nanoPower

В статье описан практический опыт разработчика, применившего повышающий DC/DC-преобразователь MAX17225. В результате ряда практических экспериментов, потребовавших существенного обновления технической базы компании-разработчика, автор убедительно доказывает преимущества выбранного компонента и схемотехнической реализации. Увеличенное на 50% время автономной работы лучше других аргументов говорит об эффективности конвертеров MAX17225, а также о важности предварительной оценки элементной базы.

Подробнее

Цитата

Увеличил с3 до 15пик

Да что за люди? Не трогайте С3, корректируйте сначала Миллера! Вы читаете, что Вам пишут?

С11 и С14 нужно увеличивать.

Для начала.

Вот пост Спиридонова из темы про тройку, актуально и тут.

 

Edited by finn32

Share this post


Link to post
Share on other sites

Я сразу запускал с 49710, все получилось, кроме некоторых нюансов. Потом, когда Лучезар прислал 49990, попробовал ее. Не пошла совсем, оставил ее в покое. Зато хорошо пошла OPA827. С ней и слушал. 

Share this post


Link to post
Share on other sites

Кстати, пробовал 49990 еще в паре усилителей- та же картина. Так что...:unsure:

Share this post


Link to post
Share on other sites

Пробовал ставить LME49710NA. Ситуация такая же. Усь так же возбуждается. Завтра на работаю в поле. В пятницу опять засяду менять с12 с13. ОУ с ебея.   просадки по уна 60в нет. По ВК не посмотрел

Edited by vova07

Share this post


Link to post
Share on other sites

Ставил в двойку LME49990. Коррекция была следующая: С11, С12, С13,С14- 33pF, С20- 100pF, С5- 22pF, С3- 10pF. Стабильно работало (пока не разобрал).

Share this post


Link to post
Share on other sites
9 часов назад, klaid1971 сказал:

надеюсь звук того стоил

Да, звук был хороший, очень детальный. Но это заслуга всего усилителя. Изначально делал два варианта- классическая двойка и безООСная. Вторая понравилась больше- её и оставил. Но нормально настраивался и первый вариант.

Share this post


Link to post
Share on other sites

Други, помогайте, встал в небольшой тупик. Уже почти все упаковал, но возникла проблема. В усилителе использую 2 платы Att5 и контроллер от Максима. так вот, при соединении всего этого левый канал начинает заводиться. Осциллографом не смотрел, но зажигаются светодиоды УНа и начинает сильно греться. При отключении шнурка от Att5 к усилителю косяк прпадает, так же пропадает если отключить шлейф управления (IDC6) от одного из каналов.

Где-то тут собака порылась, но вот не могу понять что делать дальше. 

Платы РГ соединены как на фотографии.

nataly.gif

att5.jpg

Edited by pryanic

Share this post


Link to post
Share on other sites

Земли так соединены. На каждой плате Att5 земля контроллера соединена с сигнальной землей через резистор и через шлейф все это соединено с землей контроллера. 

ground.jpg

Share this post


Link to post
Share on other sites

Так все было настроено отдельно и поканально и только после этого приступил к сборке в корпус.

Вот те на, переткнул все шлейфы и сейчас все норм работает. Понаблюдаю еще)

Share this post


Link to post
Share on other sites

Не, я уже пробовал запускать и частично собранный в корпусе, все было норм. Чето с регулятором какой-то глюк видать произошел. Бум проверять. 

Share this post


Link to post
Share on other sites

Слав, естественно для контроллера отдельный дежурный блок питания.

Share this post


Link to post
Share on other sites
В 05.02.2017 в 21:17, pryanic сказал:

через шлейф все это соединено с землей контроллера. 

 

Может шлейф где то неконтачит? И судя по рисунку,у Вас "земля"  от БП только на один канал идёт)) Да и не в земле дело,а наверно всё таки в контактах шлейфа..Была такая история,((

Share this post


Link to post
Share on other sites

День добрый. Долго и нудно по-немногу, по-маленечку собирал данную конструкцию. Жёг детальки по случаю, разбирался что к чему. Сейчас ток УНа -  20мА, по 28-33мА на транзистор ВК (в разных каналах). ОУ - LM318N и LT318A (без разницы между ними, иное пока не пробовал). Питание +/-44.5, +/-54.7, проседает до 41В ВК (на 8Ом и до 40В при 4), в УН просадок не заметил вовсе.Клип начинается на 40 В выходного сигнала (+/- в зависимости от нагрузки, светодиоды едва заметны в темноте). Номиналы по схеме кроме R45, R49 (порядка 2кОм). В одном из каналов симметричны, в другом номиналы этих резисторов на 30% разнятся (не вижу идеологических поводов к беспокойству - прав ли?). Напряжения по схеме практически симметричны, на выходе доли милливольта (плывут на 0.2мВ при полном прогреве).

Проблема - подвозбуд при клиппинге (аналогично последним фотографиям @vova07). С этим, как понимаю, надо бороться увеличивая ёмкости C11 и C14 (так ли?).

Но главная бяка - приличная амплитуда нечётных гармоник. Чётные вплоть до упора в питание практически не отлавливаются. На 1кГц синусе, к примеру, амплитуда 3кГц порядка -74дБ, доходит до -69дБ в зависимости от нагрузки (варьирую от 4-8-12Ом). Куда смотреть? Сигналы подаю через ПУ. На выходе ПУ контролирую - там всё гладко. Даже чище, чем подать прямо на УМ, поскольку выходное сопротивление ЦАПа высоковато.

АЦП - диф, к земле УНЧ не притянут (петель нет). При игре с землёй внутри корпуса (в т.ч. поочерёдное отсоединение всех модулей (кроме трансформатора, БП и, собственно, оконечника) не приводят к сколько-нибудь вообще заметному изменению результата (в разобранном виде подаю синус на оконечник с другого источника, его контролирую). 3я и 5я гармоники.

Темы (эту и около) уже не первый год листаю, вычитывать полностью уже сложно. Пните в нужную сторону, если не увидел куда смотреть, пожалуйста. Грущу, THD порядка 0.02..0.09%. Или это нормально для данной версии?..

Share this post


Link to post
Share on other sites

Где-то свистит. Надо подавать меандр,и смотреть.

Edited by tsf54

Share this post


Link to post
Share on other sites
В ‎07‎.‎03‎.‎2017 в 14:06, Slownegg сказал:

День добрый. Долго и нудно по-немногу, по-маленечку собирал данную конструкцию. Жёг детальки по случаю, разбирался что к чему. Сейчас ток УНа -  20мА, по 28-33мА на транзистор ВК (в разных каналах). ОУ - LM318N и LT318A (без разницы между ними, иное пока не пробовал). Питание +/-44.5, +/-54.7, проседает до 41В ВК (на 8Ом и до 40В при 4), в УН просадок не заметил вовсе.Клип начинается на 40 В выходного сигнала (+/- в зависимости от нагрузки, светодиоды едва заметны в темноте). Номиналы по схеме кроме R45, R49 (порядка 2кОм). В одном из каналов симметричны, в другом номиналы этих резисторов на 30% разнятся (не вижу идеологических поводов к беспокойству - прав ли?). Напряжения по схеме практически симметричны, на выходе доли милливольта (плывут на 0.2мВ при полном прогреве).

Проблема - подвозбуд при клиппинге (аналогично последним фотографиям @vova07). С этим, как понимаю, надо бороться увеличивая ёмкости C11 и C14 (так ли?).

Но главная бяка - приличная амплитуда нечётных гармоник. Чётные вплоть до упора в питание практически не отлавливаются. На 1кГц синусе, к примеру, амплитуда 3кГц порядка -74дБ, доходит до -69дБ в зависимости от нагрузки (варьирую от 4-8-12Ом). Куда смотреть? Сигналы подаю через ПУ. На выходе ПУ контролирую - там всё гладко. Даже чище, чем подать прямо на УМ, поскольку выходное сопротивление ЦАПа высоковато.

АЦП - диф, к земле УНЧ не притянут (петель нет). При игре с землёй внутри корпуса (в т.ч. поочерёдное отсоединение всех модулей (кроме трансформатора, БП и, собственно, оконечника) не приводят к сколько-нибудь вообще заметному изменению результата (в разобранном виде подаю синус на оконечник с другого источника, его контролирую). 3я и 5я гармоники.

Темы (эту и около) уже не первый год листаю, вычитывать полностью уже сложно. Пните в нужную сторону, если не увидел куда смотреть, пожалуйста. Грущу, THD порядка 0.02..0.09%. Или это нормально для данной версии?..

Пробовал подбирать все емкости, увеличивал, уменьшал. Изменил питание как на трешке. Ставил лме49710 вместо лм318. Так и не победил возбуд.  Он идет уже с операционника.  Питалово чистое. Возбуд 5 мгц.  Либо монтаж. Либо ???????  Но еще руки не опустил. На меандре все чисто. С5  поставил 15пкф     25пкф конечно все будет чисто. но быстродействие затормозится.

   

Edited by vova07

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...