Jump to content
admin

Осциллограф DSO138 - конструктор

Recommended Posts

Добрый всем день!

Спаял эту игрушку. Вылезла проблемка - при питании от кроны, через несколько минут перестаёт отображаться сигнал. Экран светится белым.

Что может быть? Подозреваю Стаб на +5в. Может перегревается? Пощупать пальцами - не получается, пальыф толстоваты :).

Стоит его менят на более другой?

Share this post


Link to post
Share on other sites

Он потребляет примерно 150 мА. Для " Кроны " это большая нагрузка, поэтому она долго не тянет. Я питаю от сетевого адаптера на 9 В постоянного тока. Не помню от чего он.

Share this post


Link to post
Share on other sites

Приветствую,

получил микросхемы,кто подскажет, кроме как ST-LINK ,чем можно еще прошить?

Share this post


Link to post
Share on other sites

Финальные результаты тестирования литиевых батареек FANSO при нормальных условиях

Перед разработчиком устройства, в котором предполагается использование батарейки, всегда стоит задача выбора того или иного бренда. Конечно, наиболее объективный результат по качеству можно получить при реальном тестировании в режиме работы самого устройства. Для того чтобы у разработчиков была некоторая информация о реальных значениях основных параметров ЛХИТ, инженеры компании КОМПЭЛ решили провести серию из трех тестов. Первый тест на постоянный разряд в нормальных климатических условиях, начатый в апреле 2019 г., мы завершили.

Узнать финальный результат тестирования

Приветствую,

получил микросхемы,кто подскажет, кроме как ST-LINK ,чем можно еще прошить?

Чем Вас не устраивает инструкция по прошивки dso138 (через uart)?

И здесь и на коте детали обсуждались.

Я Вам писал: ничего дополнительного не требуется.

Запаяете камушек и прошьете через уарт, зачем усложнять?

Edited by a797945

Share this post


Link to post
Share on other sites

Спасибо,

Вы можете объяснить как это делается,через этот интерфейс,я почему спрашиваю,потому как я только начинаю изучать как работать с микроконтроллерами.Буду признателен за подсказку.

вот моя электронка: vlad-mochalov@yandex.ru

Share this post


Link to post
Share on other sites
                     

Видеокурс Работаем с микроконтроллерами STM32G0. Впервые на русском языке.

В цикле видеокурсов по работе с STM32G0 от компании STMicroelectronics показаны архитектура, периферия (особенности процессорного ядра, режимов пониженного питания, векторов прерываний, DMA и мультиплексора DMA, схемы тактирования и сброса, и.т.д.) и даны практические примеры. Материал дает наглядное понимание того, как начать работу на новых микроконтроллерах STM32G0

Подробнее

Так все уже обсуждалось прочтите ветку с начала или хотябы с #158 и видео было,

аналогичное но с другими вопросами было на радиокоте. Это что касается dso138.

Если вообще по камням stm32 - забейте в поисковик " прошить stm32" найдутся описания и других способов.

Share this post


Link to post
Share on other sites

еще вопрос,у меня не устанавливается flash loader,выдает ошибки или на XP Не устанавливает?

Share this post


Link to post
Share on other sites

Спасибо,

Вы можете объяснить как это делается,через этот интерфейс,я почему спрашиваю,потому как я только начинаю изучать как работать с микроконтроллерами.Буду признателен за подсказку.

вот моя электронка: vlad-mochalov@yandex.ru

http://www.jyetech.com/Products/LcdScope/DSO138_oscilloscope_upgrade.pdf

еще вопрос,у меня не устанавливается flash loader,выдает ошибки или на XP Не устанавливает?

http://www.st.com/st-web-ui/static/active/en/resource/technical/document/user_manual/CD00171488.pdf Тут на стр 5 написано, что можно ставить

Share this post


Link to post
Share on other sites

Приветствую. Вот тоже приобрел и собрал девайс. Заработал сразу. но есть пару воросов:

1. Луч находится на -0.4в при замкнутых щупах. В ноль выставить курсором можна его но эти 0.4 в сказываются не результатах.

2. Когда курсор тригера выставляю в 0, на дисплее уровень триггера отображается -0.6в.

3. Через 2-3 минуты работы перестает вызываться меню измерения. Причем если оно было запущено то потом выключить его невозможно. Только после перезагрузки.

post-100679-0-24098900-1453028151_thumb.jpg

Share this post


Link to post
Share on other sites

Приветствую. Вот тоже приобрел и собрал девайс. Заработал сразу. но есть пару воросов:

1. Луч находится на -0.4в при замкнутых щупах. В ноль выставить курсором можна его но эти 0.4 в сказываются не результатах.

2. Когда курсор тригера выставляю в 0, на дисплее уровень триггера отображается -0.6в.

3. Через 2-3 минуты работы перестает вызываться меню измерения. Причем если оно было запущено то потом выключить его невозможно. Только после перезагрузки.

1. - на ноль выставляется подбором сопротивления R10. Об этом здесь уже писали. И делаете корректировку 0. Клавишами HOLD

2. - сам пока не разобрался

3. - Меню измерений выводится только когда выбор (нижняя клавиша) стоит на времени развертки.

Share this post


Link to post
Share on other sites

1. - на ноль выставляется подбором сопротивления R10. Об этом здесь уже писали. И делаете корректировку 0. Клавишами HOLD

2. - сам пока не разобрался

3. - Меню измерений выводится только когда выбор (нижняя клавиша) стоит на времени развертки.

Спасибо. Я форум бегло просмотрел и видимо кое что пропустил. Ну буду разбираться. И еще вопросик: при открытом входе он не измеряет параметры частоты и периода. Т.е он меряет сигнал только когда он переходит через 0?

Share this post


Link to post
Share on other sites

подскажите можно ли измерить шумы от блока питания robiton SN1000S http://www.robiton.ru/product/04401 с помощью стандартных крокодилов от DSO138 покажет ли что нибудь dso138 ?

Edited by lexxlex

Share this post


Link to post
Share on other sites

В том то и дело что просто маленькие шумы так то он нормально работает - а щуп 100mhz 1/10 может помочь ?

Share this post


Link to post
Share on other sites

доброго времени суток. у меня проблема после сборки dso138 :белый экран,моргает светодиод. всё делал согласно инструкции ,все напряжения в норме.подскажите кто знает как оживить этого китайца.

Edited by rim

Share this post


Link to post
Share on other sites

пропайка всех контактов. я в своем три раза пропаивал и один раз с феном. до этого такой же результат был

Share this post


Link to post
Share on other sites

спасибо ,а точнее не можешь сказать. как буд то микруха не запускается . при нажатии на ресет два всплеска на экране появляется

Share this post


Link to post
Share on other sites
спасибо ,а точнее не можешь сказать. как буд то микруха не запускается . при нажатии на ресет два всплеска на экране появляется

Если диод мигает - значит процессор работает. Пропаяйте контакты дисплея и контакты разъема. А чем питаете осциллограф?

Share this post


Link to post
Share on other sites

Кто-нибудь проверял оригинальность по ID номеру? Отправил запрос на указанный ими адрес и 4 дня тишина.

Edited by alexernst

Share this post


Link to post
Share on other sites

Большое спасибо за советы . Контакты разъма прозванивал межу платами и между собой то же. Питание бп 9в 500ма .А скажите пожалуйста без дисплея микруха будет работать? да еще ,микруха выполняет команду тест дисплея по описанию, но на экране как было так остаеся

Share this post


Link to post
Share on other sites

Большое спасибо за советы . Контакты разъма прозванивал межу платами и между собой то же. Питание бп 9в 500ма .А скажите пожалуйста без дисплея микруха будет работать? да еще ,микруха выполняет команду тест дисплея по описанию, но на экране как было так остаеся

Без дисплея будет работать, только что это даст? проц шлет команды на дисплей там, как правило однонаправленная связь (т.е дисплей только принимает комманды и никаких ответов не шлет, хотя могу и ошибаться).

Попробуйте подключить какой нибудь динамик на выход тестового сигнала(этот сигнал генерирует сам процессор, эсли он работает - услышите писк). Ну а по поводу дисплея, то если он горит белым значит не проходит инициализация. Либо где то нет контакта, либо у вас не тот тип дисплея, либо сам дисплей неисправен. Если есть доступ к другому осциллографу - можно пройтись по всем сигнальным цепям дисплея, на них должны присутствовать какие то импульсы, если они есть, и напряжения питания на соответствующих выводах присутствует, то однозначно что то не то с самим дисплейным модулем.

Share this post


Link to post
Share on other sites

А на видео в ютубе без дисплея светодиод не мигает то есть прошивка загрузилась . А по поводу сигналов то тактовый генератор работает,калибровочный сигнал 1кгц в норме .Даже когда жмёшь Reset на UART выходе пачка цыфр проскакивает короче говоря микруха как бы работает на половину а прошивка не загружается

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By zva183
      Приветствую форумчан и опять прошу помощи с моим осциллом-помощником. В общем сидел-делал блок питания и изредка проводил измерения осциллом и в один момент поворачиваюсь - а луча на экране нет. Осцилл в это время не был подключен ни к каким измеряемым цепям. Вот буквально пару минут им еще смотрел сигнал и просто отложил щуп в сторону - оппа и ничего уже не показывает. Ранее совсем давно на нем менялся кулер и часть мертвых электролитов, после этого он работал, Менялись лет 5-7 назад. + была проблема, описаная в этой ТЕМЕ. Но тогда все и осталось на прежнем месте, т.е. все напруги тогда были в норме и я не стал лезть в кишки и что-то менять, меня все устраивало.
      Итак, первым делом я замерил на колодке, куда выведены все основные напряжения и поправил их соответственно мануалу. Высокое на аноде есть: проверил немного сдвинув защитную резинку и приставив отвертку - после включения, прогрева и выключения если отвертку приближать от фишки чуть ближе к корпусу, то видно что проскакивает искра, видимо остаточное напряжение с высоковольтных кондеров. Более ничем я все, что выше 1000В, замерить не могу. Также была проверена колодка на самой ЭЛТ на предмет напряжения - там все напруги выставил по мануалу (сильно были занижены по 7 и 9 ногам колодки: +60 и +90В, вместо них были +47В и +38В). Накал есть, высокие напруги (-2000, -2050, -1620В) на колодке вроде тоже есть - тестер показывает превышение порога на этих ножках. Лампы указания положения луча по вертикали показывают что луч перемещается если крутить регулятор на блоке 1У11 "вверх-вниз", а вот лампы указания вправо-влево: горит только правая, если выкрутить регулятор вправо на основном блоке, левая лампа не зажигается ни при каких манипуляциях с регулятором "право-лево". Схема есть. Пробовал включать по мануалу с вытащенными сменными блоками - нет луча, хотя я так понял по мануалу - должен быть. На что еще обратить внимание? что я упускаю?
      P.S. попробовал отключить от плат выводы с трубки Ш7, Ш8, Ш11,Ш12 - нет луча, хотя на контактах плат куда эти провода подключаются я выставил примерно по 44в. т.е. получается в случае даже при этих подключенных проводах там примерно равная напруга и луч должен быть посередине (это все без сменных блоков)
    • By Denis Khamatov
      Имеется ослик Н313. Все бы ничего, но разъем для щупа у него какой-то нестандартный. Помогите определить, что за разъем. И имеет ли смысл искать родные щупы для него, или лучше заменить эти разъемы на что-то более стандартное?

    • By Тарас С
      Продам АКТАКОМ ADS 2061MV. Б/у
      г.Киев. Вышлю по Украине
      Работает исправно, ощутимых внешних дефектов нет. Щупов нет. Кабель питания добавлю
      Описание:
      2 канала
      Полоса пропускания - 60 МГц.
      Частота дискретизации - 500 Mвыб/с (250 Mвыб/с на канал).
      Макс. память - 10 М на каждый канал.
      Входной импеданс: 1 МОм. 
      Интерфейс: USB-host, USB-device, LAN, VGA. Дисплей: 20 см, цветной, TFT, 800 х 600. 
      Вес: 1,82 кг. Размеры: 340 x 155 x 70 мм.
       
      Ссылка на более подробное описание:
      https://elaso.com.ua/products/0-kontrolno-izmeritelnye-pribory/33-oscillografy-cifrovye-i-analogovye/name/2533-ads-2061mv

    • By tishkanexx
      Привет, делаю БП на lm317. Питаю от транса 9в 1а. Заметил что при повышении нагрузки до 559мА на осциллограмме появляются провалы. При понижении до 519мА все идеально ровно (на 5в до 1а все ровно). Для цап нужно 130мА и 8В, так что это не критично. Но как новичку интересно, что это за провалы и вообще подробнее о них. Спасибо.

    • By Sufiyarov
      По причине невостребованности продам двухканальный осциллограф С1-118 с полосой до 10МГц.
      Аппарат рабочий, запас яркости луча приличный, синхронизируется легко. 
      В комплекте самопальный пробник.
      Из нюансов: требуют профилактики или замены переменные резисторы горизонтального отклонения луча.
      Форумчанам отдам за 4000 руб.
      Упакую надёжно, отправлю удобным для вас способом.
      Местоположение: Екатеринбург.




×
×
  • Create New...