Jump to content
bulat943

Приемник на RDA5807 и семисегментнике

Recommended Posts

11 минуту назад, bulat943 сказал:

4000000/(256*(255-150)*4)=37,2 раза в секунду обновляется индикатор

 

37 Гц, а с энкодером и того меньше. Наверно мало будет. У кинескопных телевизоров частота кадровой развертки 50 Гц, и то мерцание заметно. Может, лучше увеличить где то до сотни?

Share this post


Link to post
Share on other sites

энкодер не при чем-как бы вы его не крутили частота обновления 37,2 гц-это задано программно

ничего не мерцает,вообще!

 

Share this post


Link to post
Share on other sites

@bulat943 , у меня есть вопрос по коду. А почему для индикации Вы выбрали Таймер 2? Таких примеров в сети я не встречал. Интересно узнать с чем это связано.

Share this post


Link to post
Share on other sites

Финальные результаты тестирования литиевых батареек FANSO при нормальных условиях

Перед разработчиком устройства, в котором предполагается использование батарейки, всегда стоит задача выбора того или иного бренда. Конечно, наиболее объективный результат по качеству можно получить при реальном тестировании в режиме работы самого устройства. Для того чтобы у разработчиков была некоторая информация о реальных значениях основных параметров ЛХИТ, инженеры компании КОМПЭЛ решили провести серию из трех тестов. Первый тест на постоянный разряд в нормальных климатических условиях, начатый в апреле 2019 г., мы завершили.

Узнать финальный результат тестирования

Уважаемый bulat943.

Прошил прошивкой programm 76-108 oa ok 01.hex.

Энкодер и кнопки стали работать как положено,есть небольшое мерцание,но это не критично.

Но есть одно но.

Стало больше шумов и помех.

Прием более менее нормальный в нижней части FM диапазона,у меня это 90-101.2мгц.

В верхней части,это 101.6-107.6мгц ничего не принимает,а там основная часть станций.

Ставил разные RDA модули,везде одинаково.

Хотя на прошивке  "вторая прошивка,RDA прикручен ОА.hex" все работает нормально.

Может быть это из-за легкого мерцания?

Перенес приемник в другое место(там всегда был лучший прием).

Так  станции 90-101.2мгц. идут обалденно.

А станции 101.6-107.6мгц как будто корова языком слизала.

А это не может быть.из-за того что раньше было 88-108,а стало 76-108.

Edited by vbrt

Share this post


Link to post
Share on other sites

вот развертка 61 раз в секунду (прошивка энкодер реверс-энкодер в обратную сторону)

шумы и помехи-у меня тоже появились но слабые и там где нет станций

 

 

Потому я и отключал индикацию при приеме-шумел на некоторых станциях

 

перезалил,попробуйте

 

programm 76-108 oa ok 02.hex

programm 76-108 oa ok 02 энкодер реверс.hex

Edited by bulat943

Share this post


Link to post
Share on other sites
                     

Видеокурс Работаем с микроконтроллерами STM32G0. Впервые на русском языке.

В цикле видеокурсов по работе с STM32G0 от компании STMicroelectronics показаны архитектура, периферия (особенности процессорного ядра, режимов пониженного питания, векторов прерываний, DMA и мультиплексора DMA, схемы тактирования и сброса, и.т.д.) и даны практические примеры. Материал дает наглядное понимание того, как начать работу на новых микроконтроллерах STM32G0

Подробнее

С прошивками programm 76-108 oa ok 02.hex и programm 76-108 oa ok 02 энкодер реверс.hex

мерцание исчезло, но появилась паразитная засветка неработающих сегментов.

А по приему-тоже самое.

Share this post


Link to post
Share on other sites

Уважаемый bulat943.

Прошивал прошивками: programm 76-108 oa ok 02 энкодер реверс.hex и programm 76-108 oa ok 02.hex.

Остановился на 76-108 oa ok 02 энкодер реверс.hex.

Работает все нормально.

Единственное пока замечание,это при записи всех станций в память

И снятие и последующем включение питания,в памяти постоянно появляются

три лишних частоты: 99.6/101.1/103.3.

И каждый раз их приходится стирать.

И скажите зачем вы поставили диапазон 76-108, а не 88-108.

С 76 по 90 ничего нет.

 

 

 

Share this post


Link to post
Share on other sites

прошивка реверс-энкодер при вращении в другую сторону (крутим вправо плюс,вторая прошивка реверс-крутим вправо минус)

частоты убрал,прошивка 88-108 МГц (у меня радиомикрофон на 79 МГц поэтому такой диапазон был)

 

programm 88-108 oa ok 02 энкодер реверс.hex

Edited by bulat943

Share this post


Link to post
Share on other sites

Уважаемый bulat943.

Огромное спасибо за сделанную работу.

Все работает.

Буду думать о размещение в корпус.

Хотелось бы светодиодного индикатора реального стереосигнала станции.

С уважением.

 

 

 

Edited by vbrt

Share this post


Link to post
Share on other sites

я тоже об этом думал,у нас есть свободный PORTC.2,можно повесить светодиод через резистор 510 ом

сейчас выложу,кстати,вот

индикация стерео приема-на PORTC.2 светодиод к минусу через резистор 510 ом-1 ком (подобрать экспериментально)

расшифровка пошивки-"88-108 oa ok 04 ST ER"   =ДИАПАЗОН 88-108,Общий Анод и  Общий Катод ST=СТЕРЕОИНДИКАТОР,ER=ЭНКОДЕР РЕВЕРС  

 

programm 88-108 oa ok 04 ST ER.hex

Edited by bulat943
перезалил-при выкл приемника стерео индикатор продолжал светиться

Share this post


Link to post
Share on other sites

Я сразу не заметил.

Есть паразитная засветка 1 и 3 разряда (слева направо).

Сильно заметно за красным стеклом.

Share this post


Link to post
Share on other sites

Подсветка осталась.

И что  самое интересное,подсветка 1 разряда дублирует 4 разряд,а 3-2.

А не 2 и 4 разряде подсветки нет.

Share this post


Link to post
Share on other sites

Уважаемый bulat943.

В последней прошивке засветка пропала.

А на порте РС2 постоянно сидит "1".

Share this post


Link to post
Share on other sites

у меня все работает как надо-при стерео сигнале на PORTC.2 единица,при моно-ноль (LOVE RADIO  у нас идет моно) 

при отсутствии сигнала тоже единица?

Edited by bulat943

Share this post


Link to post
Share on other sites

Сейчас импульсный.Проверял с трансформаторным,разницы не увидел.

С унч сейчас экспериментирую.Пробую PAM8403,TEA2025,CM8602B.

Еще не определился.

Share this post


Link to post
Share on other sites

запитайте от аккумулятора сотового,наушники без унч,стереоиндикато должен работать

у меня с усилителелем рам8403 полдиапазона стерео,даже если станций нет

 

Share this post


Link to post
Share on other sites

Запитал от аккумулятора,унч отбросил.

Светодиод горит постоянно.

Share this post


Link to post
Share on other sites

странно,сейчаспроверю на второй макетке

 

на второй макетке тоже стереоиндикатор работает...с вы точно подсоединили к PORTC2?

PORTC3 так и остался-выбор оа/ок

Edited by bulat943

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...