Jump to content

Recommended Posts

собрал себе программатор xprog старой версии 1.2 на pic16f84.

софт под виртуалкой на win98 с пробросом ком-порта.

софт работает, но чип не видит.

хочу прочитать MC68HC11EA9

может был опыт у кого-нибудь с этим программатором ?

Share this post


Link to post
Share on other sites

Схемку пожалуйста выложи... Я тебе не собираюсь гуглить здесь, искать твой программатор!


У человека нет возможности всем делать добро, но у него есть возможность не причинять зла.

Share this post


Link to post
Share on other sites
11 минут назад, Гар сказал:

Схемку пожалуйста выложи... Я тебе не собираюсь гуглить здесь, искать твой программатор!

не буду грубить в ответ :)

к схеме претензий нет. всё отрабатывает, вроде бы корректно.

Xprog_sch.pdf

Share this post


Link to post
Share on other sites

Приглашаем на вебинар «Инновационные технологии Analog Devices в области управления питанием» (11.08.2021)

В программе вебинара технология Silent Switcher® - сочетание высокого КПД и сверхмалого уровня ЭМИ, технология uModule® - высокоинтегрированные решения для источников питания, микро- и нанопотребляющие DC/DC-преобразователи, решения для резервного питания, цифровое управление системой питания (PSM), безоптронные изолированные обратноходовые преобразователи. В практической части вебинара будут продемонстрированы примеры работы с инструментами Analog Devices для проектирования источников питания.
Подробнее

Концевые микропереключатели KLS – простая и надежная коммутация по оптимальной цене

На складе Компэл широко представлены нажимные переключатели от KLS в стандартных и миниатюрных корпусах с различными типами актуаторов. Микропереключатели серий KLS7-KW10 и KLS7-KW4-3Z соответствуют строгим стандартам электрической безопасности и эффективности, что гарантирует надежную коммутацию цепей управления.

Подробнее

@fsem инфа интересная. посмотрел, скачал, спасибо B)

не проходит инициализация загрузчика.

сам программатор определяется ок.

Windows 98-2019-11-26-19-13-21.png

@fsem вот так пытаюсь считать. к плате припаял землю и контакты на резонатор 8мгц.

импульсы в чип летят. размах и форма сигнала в норме. что-то с чипом вероятно ?!...

IMG_0681.JPG

Edited by goodbye

Share this post


Link to post
Share on other sites

Датчики STMicroelectronics – новые возможности систем умного дома ST

Согласно прогнозам аналитиков, в ближайшие пару лет будет наблюдаться заметный рост рынка датчиков движения и положения для умного дома. Компания STMicroelectronics предлагает одну из самых широких линеек MEMS-датчиков, включая акселерометры, гироскопы, цифровые компасы, модули IMU, микрофоны и датчики параметров окружающей среды. Рассмотрим применение датчиков и тенденции их развития.
Подробнее

Вот, вроде похоже на правду. я там уже хз что должно быть правильно. но чип видимо не хочет, чтобы его прочитали.

это rxd txd сигналы с mc68hc11ea9

screenshot.png

24 MHz, 240 M Samples [2].logicdata

Edited by goodbye

Share this post


Link to post
Share on other sites
26.11.2019 в 19:15, goodbye сказал:

к плате припаял землю и контакты на резонатор 8мгц.

ни у кого нет никаких мыслей ?

С такими длинными проводами к резонатору, встроенный в чип генератор вполне может не работать. Если для программирования требуется наличие этого такта, то это вполне может быть причиной.

У этого чипа нет контрольного выхода, посмотреть есть ли внутренний такт? Этот чип не знаю, но обычно выход типа делённого на 4 делают.

Share this post


Link to post
Share on other sites

ок. посмотрю.

но осциллографом смотрел вообще есть ли сигнал от резонатора. всё ок было. осциллограф однозначно показал 8 мгц.

Share this post


Link to post
Share on other sites

@Lexter есть выход на котором присутствует ровные 2мгц.

есть даташит на этот чип. всё сходится. там должно быть 2мгц. т.е. генератор работает исправно. темболее что, инициализация чипа проходит, не проходит инициализация загрузчика...

Edited by goodbye

Share this post


Link to post
Share on other sites
26.11.2019 в 19:43, goodbye сказал:

это rxd txd сигналы с mc68hc11ea9

screenshot.png

... ни у кого нет никаких мыслей ?

Ну вот ещё одна мысль: В этой временной диаграмме  явно разный период такта у левой и правой группы импульсов. Может что-то со скоростью передачи, не так настроено?

Share this post


Link to post
Share on other sites

взял другой такой же чип, 100% рабочий.

такая же ситуация, не может инициализировать режим загрузчика. :(

осталось попробовать не эмулятор на 98 винде, а старй комп с 98 виндой и обычный ком-порт ...

Share this post


Link to post
Share on other sites

А выполнены ли условия для чтения?

Я точно не помню, там надо было некоторые ноги запаять на землю или питание.

Чёт проводов много запаяно, там 5 штук только надо, хотя, если обходим защиту и х-прогом то возможно.

Модуль знакомый, проц знакомый, вроде EWS для старых бемок.

Если неаккуратно читать и включена защита, то дамп слетает с космической скоростью... со всеми вытекающими.

Edited by ГОГА рижский

Мыши кололись, плакали, но продолжали жрать кактус.

Share this post


Link to post
Share on other sites

@ГОГА рижский

да всё верно, слетел дополнительный код в ключе, и евс3 перестал разрешать запускать двигатель. отшил эбу от евс3, пока так катаюсь, но хочу восстановить работу евс3.

вобщем, всё делаю как по инструкции к программатору. всё равно не работает. пины которые на землю нужно замкнуть замыкаю это modA и modB.

кварц беру с платы евс, поэтому туда припаял 3 провода: 2 от ног кварца и один для земли. генерация, как писал вышел, есть.

вчера перепрошил чип, т.к. при конвертации из e2p в hex пустые места были записаны как 0000, исправил на 3FFF, ничего не поменялось в работе устройства. и ещё использую cp340 как юсб в ком порт, и подключаю к виртуальной машине с вин98, программа хпрога при запуске в других ОС более современных, сразу говорит, что не будет работать. может быть имеет смысл проверить на реальном компе с реальным компортом ? %)

Безымянный.png

Edited by goodbye

Share this post


Link to post
Share on other sites

А MOD B  никуда не подключается? !!!

Reset не требуется подтянуть к + ? Проверьте осциком.

Маска 2D47J проц под защитой. 

подключение:

17 - Reset

3 -   MODA  на землю

22 - MODB на землю

20 - RXD

21 - TXD

Программировал в составе блока Сможете тут разобраться? Массу отыскать легко, а питание всегда идёт через диод.

IMG_20191210_130618.thumb.jpg.d278fc3b7a2012ecf2f1ef4e5e4c411f.jpg

 

Вы программируете выпаянный проц. А все ли питания подходят?

141455779_119.jpg.e10639c755fc60b5bdb836cee4a4a1f7.jpg

прозвоните на печатке 52 и 51 ногу.

Если проц не под защитой ( смотрите маску ) я программировал программой MotCrack 6.2 в составе блока, т.е. внутрисхемно.

Конектится моментом, при чтении защищенного проца слетает EEPROM - FF в буфере.

 

Edited by ГОГА рижский

Мыши кололись, плакали, но продолжали жрать кактус.

Share this post


Link to post
Share on other sites

@ГОГА рижский у меня маска без защиты 0D46J, я выпаял чип с платы, но есть ещё один евс, там чип впаян ещё на плату. т.е. и так и так могу проверить.

и я питания не все подключил, я делал как в инструкции к хпрогу (картинку сверху прикладывал это оттуда) модБ там это контакт снизу, правее rxd.

а MotCrack он с хпрогом будет работать ? или для него своё железо нужно ?

Edited by goodbye

Share this post


Link to post
Share on other sites

@ГОГА рижский

51 и 52 ноги заземлены на печатке.

Сигнал сброса без подтяжки, осциллографом посмотрел, отрабатывает четко! на плате тоже нет подтяжки к + этого сигнала.

чип данные принимает, это видно по индикации rx tx программатора, и диаграммы лог анализатора выше подтверждают это.

Share this post


Link to post
Share on other sites

Замкни МодБ на массу. Или проц не будет читаться. Я всегда замыкал его на массу.

У MotCrack своё железо простое на MAX 232. Требуется старый комп с 98 ( ХР ? ) виндой и СОМ портом.

 


Мыши кололись, плакали, но продолжали жрать кактус.

Share this post


Link to post
Share on other sites

Значит прогер запрашивает не то что надо.

С хпрогом работал мало, у нас было несколько штук. Один оригинальный и клон ещё был.

Что с хпрогом, что мотокраком коннект, если выполнить все условия, был моментальный.

Запаиваешься по картинке, кнопочку нажимаешь и всё в порядке - дамп в буфере... или FF, если не повезёт )))

 


Мыши кололись, плакали, но продолжали жрать кактус.

Share this post


Link to post
Share on other sites

попробую собрать моткрак, но думаю и с ним тоже самое будет... хотя, хочется верить в лучшее ! :)

Share this post


Link to post
Share on other sites

Может к делу не относится, но я работал то ли с 98 виндой, то ли с хр.

Ещё, частоту кварца выставляли? 

Работал внутисхемно в составе блока.


Мыши кололись, плакали, но продолжали жрать кактус.

Share this post


Link to post
Share on other sites

хм.. в ОС понял.. стоит попробовать другой комп... по древнее... я из win10 пытаюсь, но там уже давно нет прямого доступа к портам com и lpt. хотя willem programmer норм работает... хз ..

частоты выставлял 8 мгц, пробовал разные... вдруг чего не так...

я работаю выпаивая... попробую внутри схемы... но всё это шаманства какие-то, не вижу закономерности, почему не работает. импульсы они и в африке импульсы....

Share this post


Link to post
Share on other sites

собрал такую версию. нашёл на аналогичном форуме, там автор пробовал через моткрак, но ничего не заработало, собрал этот и всё за 1 секунду законнектилось.

у меня не заработало, осциллографом посмотрел, всё в норме, данные как и положено летят в обе стороны.

пробовал на ноуте с железным ком-портом и винХР

 

schem.jpg

Edited by goodbye

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Сообщения

    • Здравствуйте друзья. Прошу помощи,не могу разобраться с зарядным устройством,вернее его отремонтировать. https://ibb.co/rv88HGr  В нем вход переменное напряжение 120-240 вольт и выход постоянное напряжение 24вольта,35А. https://ibb.co/nz3hTvN.  Подаю на клемму аккумулятора напряжение (подключаю аккумулятор),любое от 12-24,табло зарядного устройства работает,все установки на экране можно кнопками устанавливать. Включаю в розетку , зарядное устройство не работает,не заряжает. На входе питания 120-240Вольт стоят 3 резистора 100 Ом 7Ватт. Они потемнели, но в порядке,я их измерил. https://ibb.co/TTYHYPy Цепь разрывают контакты реле. Само реле 24Вольта,оно управляется из "глубины электроники", наверное автоматически отключает импульсный источник питания,когда аккумулятор полностью зарядится. https://ibb.co/svJJjmm  Я по глупости, попробовал замкнуть его контакты и получил КЗ,выбило автомат. https://ibb.co/sHWknS8  Получается сейчас реле ,независимо от подключенного или отключённого аккумулятора,всегда в разрыве. Если бы ни так,оно делало бы постоянно КЗ. Может его контакты выгорели и оно просто теперь не работает?  Но в любом случае, импульсный блок питания скорее всего не работает ,при подаче на него напряжения(механическое замыкание контактов реле), получается короткое замыкание. Буду очень благодарен за любые советы и подсказки по моей теме!      
    • Что то на сказку похоже. До вас что "эффективные менеджеры" не добрались?
    • Да, печаль беда, можно разобрать трансформатор и намотать новую обмотку. 
    • Ну и D3 проверить, вполне может быть и кз на выходе. Да и прозванивать надо в положении переключателя на два положения в право, там диодик и символ звука нарисованы.
×
×
  • Create New...