Jump to content
AS7ti6K

фильтры по питанию или дело в другом?

Recommended Posts

Здравствуйте. Сразу извиняюсь за много текста, но напишу подробно что я делал, прежде чем задать вопрос.
Собрал устройство. Оно из двух частей. Первая часть: Ардуино, LCD2004I2C, Енкодер, "сирена" + для нее повышающий dcdc.
Вторая часть. Модуль реле 6 шт., 74HC595N, БП 220 5в 700мА. (нагрузка реле, использовал пока только два из шести, лампа 500ватт и вентилятор 30ватт)
Соединяются части витой парой через разъемы(стандартные розетки) и штекера RJ-45.
Витая пара: Белокоричневый/коричневый - питание.
D9 - (white green    ST_CP)     "защелка"
D10- (green            SH_CP)     "такты"
D11- (orange        DS)        "данные"
D12- (white orange    OE)        "Enable"
Dxx - соответственно пины ардуины.

Первый запуск. При срабатывании реле, притухает экран и на первый-третий раз срабатывания реле виснет ардуина.
Что сделал. Поставил X2 конденсатор параллельно нагрузке. (лампе)
Виснуть перестала. Но притухание экрана осталось и через несколько срабатываний реле - они начинали срабатывать хаотично.
Поставил в код строку, которая выводит байт перед отправкой на 74HC595N. Байт уходит верный. Значит "косячит" 74HC595N.
Нашел в инете что нужно поставить конденсатор между защелкой и землей 0,1мкф. керамика. Поставил.
Стало получше. Работа реле стала более стабильной. Но иногда всеж происходит какой-то сбой.
Питалось все это от одного маленького БП, который выше указан. Решил переделать схему питания.
Что сделал. (До этого были только модули соединенные между собой проводами либо монтажной платой.)
В первой части устройства добавил электролит 1000мкф и керамику 0,33мкф на питание возле ардуины.
Во втором добавил второй такой же блок питания только на 1А. 1Амперный блок пустил только на JVCC - GND реле.
на выходы обоих блоков по керамике 0,1 мкф. На выход блока, который запитывает 74НС595 и дальше через витую на первую часть устройства, поставил электролит на 1000мкф. Включил. Стало не лучше. Ардуина не виснет и экран не притухает. Все плюсы кончились. Реле ведут себя вообще не понятно.
Думал перепутал провода (было такое один раз) на 74HC595N, проверил несколько раз, и прозванивал и визуально - все правильно с праводами.
Сделал и залил тестовый скетч который посылает на 74HC595N байты (B11111110, B11111101, B11111011... ну и т.д...) с паузой в 250мс.
Т.е. реле должны по одному вкл на 250мс и выключаться. Запустил Секунд 15 работает как положено(как прописано в скече) но потом начинается, реле сходят с ума, включаются/выключаются хаотично, но бегание по реле (как задумано) вроде продолжается. 74HC595N - менял - тоже самое.

Почему такое может происходить? Если нужны фото и видео могу позже сделать.

Вот думаю выкинуть 74НС595 и попробовать по витой паре напрямую на реле с ардуины управление сделать (два провода питание оставить и остальные шесть на реле). Я с 74НС595 хотел освободить два провода для протокола I2C... но можно кинуть еще одну витую для этого между частями. Или это не решит проблему, как считаете? Признаюсь, в электронике не очень. Закон ома знаю но с трудом понимаю.

Edited by AS7ti6K

Share this post


Link to post
Share on other sites

Ну вообще схему нужно выкладывать что вы там наваяли, ради уважения. Или нам угадывать. Длинна провода какая?

Share this post


Link to post
Share on other sites

Изготовление 2-х слойных плат от 2$, а 4-х слойных от 5$!

Быстрое изготовление прототипа платы всего за 24 часа! Прямая доставка с нашей фабрики!

Смотрите видео о фабрике JLCPCB: https://youtu.be/_XCznQFV-Mw

Посетите первую электронную выставку JLCPCB https://jlcpcb.com/E-exhibition чтобы получить купоны и выиграть iPhone 12, 3D-принтер и так далее...

@AS7ti6K Прежде, чем подключать реле, необходимо изучить вопрос про самоиндукцию и обязательно принимать меры по борьбе с ними, что бы не было вопросов, откуда импульсы на витой паре в сотни вольт, вызывающие зависания и сгорание элементов.

Прежде, чем использовать витую пару, необходимо выяснить сопротивление той самой витой пары, что бы знать падение напряжения при данном токе, что бы не было вопросов, почему всё "тухнет".

Вот два варианта, какой у тебя, первый с отдельными источниками, или второй с гальванической развязкой и одним источником? И то, для дисплея питание, возможно, потребуется отдельное, так как длинные и тонкие провода нельзя будет использовать, на входе будет 5 вольт, на проводе 2 вольта, и на дисплее даже трёх вольт не будет...

image.png.cb65645612adfe78b2baebf612721448.png

Неужели самому нельзя сразу схему сюда прикрепить, с указанием длинны проводов. Что бы не гадать. Ну и фотографиями подкрепить, только не надо ёжика в темноте присылать! Должен быть виден на фото каждый момент.

Edited by motoandrey14

Share this post


Link to post
Share on other sites

Безмостовые ККМ для 99% КПД!

Схема коррекции коэффициента мощности (ККМ) на основе так называемого «тотемного столба» (Totem Pole) обладает минимально возможными потерями и потенциально может обеспечить самые жесткие требования к энергоэффективности источников питания. Компания Wolfspeed представляет референсную разработку – плату ККМ CRD-02AD065N на базе собственных карбид-кремниевых MOSFET и диодов с наилучшими в отрасли характеристиками.

Подробнее

Питание реле должно быть от отдельного источника питания с полной гальванической развязкой, снабберные цепи на контакты реле и грамотная разводка платы и соединений. Это минимум что нужно сделать. Ну а притухание экрана, это явно источник питания не "вытягивает"  нагрузку, либо потери на соединениях. Опять же, без схемы мало что можно сказать. Может у Вас длина линии 100500 метров и всё питание теряется в проводах.

Share this post


Link to post
Share on other sites

Гибридные IGBT - сила Si и SiC в одном корпусе!

Компания Infineon представила новые гибридные IGBT-транзисторы на 650 В, которые сочетают в себе преимущества технологий TRENCHSTOP и CoolSiC. Использование SiC-диода Шоттки позволяет значительно расширить возможности IGBT и снизить уровень энергии, необходимой для включения транзистора (Eon), а также уменьшить потери на переключение.

Подробнее

2 часа назад, Yuriy.pv сказал:

Ну вообще схему нужно выкладывать что вы там наваяли, ради уважения.

Извиняюсь. Схемы как таковой нет. Отдельные готовые модули соединил в кучу. Но я понял, чуть позже попробую нарисовать схематично и сфоткать для наглядности.

2 часа назад, Yuriy.pv сказал:

Длинна провода какая?

Длина провода витой пары будет меньше 3 метров. Я изначально пробовал с трехметровым пачкордом(стандартным заводским). Но потом пробовал и с 50см пачкордом - результат одинаковый.

@motoandrey14 По поводу защитного диода я в курсе. Но так как использую уже готовый релейный модуль, то он там присутствует.... так же есть опторазвязка. И во втором моем случае, когда я добавил второй блок питания, то реле и ардуина связаны только через катушки первичных обмоток трансформаторов в импульсных бп.

2 часа назад, motoandrey14 сказал:

Прежде, чем использовать витую пару, необходимо выяснить сопротивление той самой витой пары, что бы знать падение напряжения при данном токе, что бы не было вопросов, почему всё "тухнет".

Тухло когда был один БП. С отдельным БП даже от которого все запитано кроме обмоток реле - норм.

2 часа назад, motoandrey14 сказал:

Вот два варианта, какой у тебя

Ни первый и не второй. Прошу прощенья, что сразу не нарисовал схему.... Попозже нарисую. А так скажу ардуина и дисплей рядом в одном корпусе. Дисплей притухает на доли секунды именно в момент срабатывания реле.

2 часа назад, motoandrey14 сказал:

Неужели самому нельзя сразу схему сюда прикрепить, с указанием длинны проводов. Что бы не гадать. Ну и фотографиями подкрепить, только не надо ёжика в темноте присылать! Должен быть виден на фото каждый момент.

Ок. Сделаю.

2 часа назад, samogon сказал:

Ну а притухание экрана, это явно источник питания не "вытягивает"  нагрузку, либо потери на соединениях.

Оно притухает практически незаметно, мырг и все норм. В момент срабатывания реле.

 

2 часа назад, samogon сказал:

либо потери на соединениях.

там по витой паре 5 вольт и ток максимум 200мА идет (ардуина + дисплей + энкодер + сирена (но она даже не разу не включалась т.е она не брала питание)  Провода в одной розетке запаял, а во второй стандартно обжал. Единственно - эти обжимки для одножильного провода, я обжал многожильный(которые в гибких пачкордах идут) Но я соединения проверил 2 Ампера держат. Аккумулятор через это соединение и мултиметром "прозвонил". Сравнил результат с "мультиметр сразу на аккум" - теже 2 Ампера. Мне сразу не понравилось это соединение, но после данного теста как-то немного успокоился. Схему попозже сделаю

Share this post


Link to post
Share on other sites

Вебинар «Параметры выше, цена ниже. Обновление в линейке AC/DC- и DC/DC-преобразователей MORNSUN» (26.01.2021)

Приглашаем 26 января на бесплатный вебинар, посвящённый преимуществам и отличиям новых источников питания и DC/DC-преобразователей Mornsun. На вебинаре будут рассмотрены изолированные и неизолированные DC/DC-преобразователи последнего, четвертого, поколения (R4) и компактные модульные источники питания второго и третьего поколений (семейства LS/R3 и LD/R2) на плату. Рассмотрим новую группу продукции – встраиваемые источники питания в кожухе.

Подробнее

Снабберные цепи параллельно контактам реле обязательно нужно ставить. Особенно при работе на мощную и индуктивную нагрузку. Любой искровой разряд - это электромагнитный импульс, который наводит в проводниках "иголки" высокого напряжения. Этот импульс может быть воспринят как бит информации при обмене данными, соответственно устройство получит неверную информацию "со всеми вытекающими". И процессы эти, не предсказуемы. Для начала локализуйте проблему. Например поклацайте реле без подключения нагрузки вообще и с нагрузкой. Если без нагрузки всё норм, то сами понимаете где проблема. Если будет то же самое, то проблему ищите в схеме или коде.

Share this post


Link to post
Share on other sites
19 часов назад, samogon сказал:

Снабберные цепи параллельно контактам реле обязательно нужно ставить.

Я вначале говорил, что поставив X2 конденсатор (из компового БП) .47К 275v зависания прекратились.

Но снабберные цепи я не исключаю. Я не умею подбирать номиналы. Позже сделаю. Хотя проблема может и в этом только.

19 часов назад, samogon сказал:

Например поклацайте реле без подключения нагрузки вообще и с нагрузкой.

Пробовал и так и так. X2 конденсатор переместил с контактов нагрузки ближе к Блокам питания. (На фотках будет видно). Результат одинаков.

Т.е. Ардуина сейчас не зависает, но работа ее идет не так как задумано.. Сейчас выложу фотки и попробую видео.

Тут вот еще какая ерунда. Пока все это рисовал, фоткал.... Сделал еще один тестовый скеч. Залил.... (это как раз то что на видео будет и сам скеч ниже) В общем реле работают "как надо" но сигнал как-то раздвоился что ли.... В общем я в замешательстве полном.

Вот "схема":

Dev.jpg.7d2849007e9ea05af09675599c8571be.jpg

Общий вид всего девайса:

IMG_20201127_121856.thumb.jpg.46da6d630743077002c63081d567d89c.jpg

витая пара всего 50см.

Внутри "мозгов":

IMG_20201127_122004.thumb.jpg.8a9b7661de781e948736966e49259244.jpg

Общий вид блока реле с открытой розеткой:

IMG_20201127_121949.thumb.jpg.879f10b95a375df6c84ab0dce8ccd593.jpg

В левом верхнем углу желтый прямоугольный с красной полосой - X2 конденсатор, справа от него дво Блока Питания

с желтым трансформатором 700мА, с синим 1А (он только на обмотки реле).

Крупнее:

IMG_20201127_122022.thumb.jpg.7f516b898f81a51eaa90e0e240d4e8d6.jpg

К сожалению видео не получается залить. Размер большой получился(

Сейчас попробую на яндекс диск его загрузить

Share this post


Link to post
Share on other sites
7 минут назад, AS7ti6K сказал:

сигнал как-то раздвоился что ли

В каких направлениях?

Share this post


Link to post
Share on other sites
20 часов назад, samogon сказал:

Снабберные цепи параллельно контактам реле

 

8 минут назад, AS7ti6K сказал:

конденсатор переместил с контактов нагрузки ближе к Блокам питания

А смысл? Вы читаете через строку?

8 минут назад, AS7ti6K сказал:
20 часов назад, samogon сказал:

Например поклацайте реле без подключения нагрузки вообще и с нагрузкой.

Пробовал и так и так.

Ну и? Результат?

 

Если городить всё подряд в одну кучу, то вы не определите источник проблем. Я же сказал, локализуйте проблему, а то не понятно, скетч у вас кривой или схема, или ещё что.

Edited by samogon

Share this post


Link to post
Share on other sites
17 минут назад, sanya110 сказал:

В каких направлениях?

На видео видно. Словами - реле срабатывает не одно, а сразу по два. Хотя вот скеч:

Скрытый текст

#include <LiquidCrystal_I2C.h>

#define pinLatch  9         //ST_CP pin 74HC595 "Защелка"
#define pinClock  10        //SH_CP pin 74HC595 "Такты"
#define pinData   11        //DS pin 74HC595    "Данные"
#define pinOE     12        //OE pin 74HC595    "Enable"

LiquidCrystal_I2C lcd(0x27, 20, 4);

void setup() {                                                // --------- SETUP ------------------
  Serial.begin(115200);
  pinMode(pinData, OUTPUT);
  pinMode(pinLatch, OUTPUT);
  pinMode(pinClock, OUTPUT);
  pinMode(pinOE, OUTPUT);
  digitalWrite(pinOE, LOW);
  lcd.init(); lcd.backlight();
}

void UpdateChannelState(const byte _bb) {
  digitalWrite(pinLatch, LOW);
  shiftOut(pinData, pinClock, MSBFIRST, _bb);
  digitalWrite(pinLatch, HIGH);
}

byte bb[10] = {B11111110, B11111101, B11111011, B11110111, B11101111, B11011111, B00000000, B11111111, B00000000, B11111111};
void loop() {
  for (byte n = 0; n < 4; n++) {
    lcd.setCursor(0, n);
    lcd.print("                    ");
    lcd.setCursor(0, n);
    for (byte k = 0; k < 10; k++) {
      UpdateChannelState(bb[k]);
      Serial.print(k); Serial.print(" - "); Serial.println(bb[k]);
      if (k<5) {lcd.print(bb[k]); lcd.print(",");}
      delay(500);
    }
    delay(1500);
  }
}

Кстати на видео видно (15 секунда) что при подачи питания сработали пару, хотя этого не должно быть.

16 минут назад, samogon сказал:

Ну и? Результат?

Ну я же там выше отметил - что результат одинаков.

По поводу снабберных цепей я тоже говорил:

28 минут назад, AS7ti6K сказал:

Но снабберные цепи я не исключаю. Я не умею подбирать номиналы. Позже сделаю. Хотя проблема может и в этом только.

И сейчас тесты идут БЕЗ нагрузки, поэтому контакты реле не должны искрить и мешать логике....

16 минут назад, samogon сказал:

А смысл? Вы читаете через строку?

Нет, я стараюсь все понять что мне отвечают

Видео смог только сюда (~170mb):

https://my-files.su/y5r8xi

Edited by AS7ti6K

Share this post


Link to post
Share on other sites
2 минуты назад, AS7ti6K сказал:

Ну я же там выше отметил

Не понятно просто, про конденсатор Вы говорили или про тест реле без подключения нагрузки. Не нужно всё в кучу при ответе смешивать, это вводит в заблуждение. :)

Share this post


Link to post
Share on other sites
Только что, samogon сказал:

это вводит в заблуждение. 

Виноват :) тороплюсь....(

Share this post


Link to post
Share on other sites

Что интересно, когда я экспериментировал с одним блоком питания. Добавлял конденсатор 0,1мкф между защелкой и землей прямо в разъем розетки(на фото 74НС595 в ее(розетки) корпусе находится) не паял, а так воткнул, проверил соединение есть и протестировал. Так вот этот конденсатор в прошлый раз убрал практически на 99% глюков с срабатыванием реле, 1% глюков я списал на то, что конденсатор не припаян....

На фотках выше этот конденсатор уже припаян и находится снизу платы с 74НС595 (его на фото не видно).

В общем такие изменения после первого варианта, как добавление X2 конденсатора, добавление отдельного БП для обмоток реле, установка конденсаторов на линии питания, установка конденсатора на 74НС595. Сделали некоторые вещи лучше (перестал притухать дисплей и не виснет ардуина), но глюк с работой каналов реле меня в супор ввел... (

Провода проверил, ...вроде не перепутал на 74НС595..... Ведь вроде правильно выполняется скеч, но ....не правильно. Неужели помеха может быть такой четкой (реле срабатывают по два, вместо одного)???

И еще если долго "гонять"это дело, то может иногда проскочить еще глюк такого характера. реле, помимо тех которые должны щелкнуть в определенный момент, могут щелнуть и еще другие одно, два... или три... хаотично. причем раза два так проскочит, потом опять некоторое время щелкает без глюхов(кроме сдвоения).... Но это редко случается.

Share this post


Link to post
Share on other sites

В скече строка

byte bb[10] = {B11111110, B11111101, B11111011, B11110111, B11101111, B11011111, B00000000, B11111111, B00000000,

0 - это канал включен, 1 - выключен.

Соответственно видно, что реле должны щелкать по одному. Но происходит как будто байты передаются так:

byte bb[10] = {B11111110, B11111100, B11111001, B11110011, B11100111, B11001111, B00000000, B11111111, B00000000,

выделенные добавились. из-за помехи?

Изменил строку вывода в сериал для наглядности в BIN формате сделал

Serial.print(k); Serial.print(" - "); Serial.println(bb[k], BIN);

Результат:

0 - 11111110
1 - 11111101
2 - 11111011
3 - 11110111
4 - 11101111
5 - 11011111
6 - 0
7 - 11111111
8 - 0
9 - 11111111

т.е. на 74HC595 выходит правильно, а вот доходит почему сдвоенно а иногда каша - вопрос.

 

Share this post


Link to post
Share on other sites

На схеме не понятно, как ты запитал 595! Чего не нарисовал самое главное?! Не от конденсатора  на 0.1 мкФ же питается...

И как питаются реле, и через что. В этом, что ты не нарисовал, и кроется  проблема.

Edited by motoandrey14

Share this post


Link to post
Share on other sites

 

28 минут назад, motoandrey14 сказал:

На схеме не понятно, как ты запитал 595

Ок. там просто мелко все. Но запитывал стандартно... сейчас попробую сначала на словах, потом попробую нарисовать.

74НС595

на 16 ногу +5(vcc). на 8 - gnd

конденсатор (под платой) между 8 и 12 ногой. ногу MR на VCC. ногу OE через 10 koм подтянул на vcc

Реле питаются от блока питания с синим трансформатором в контакты JD-VCC и GND. так же на модуль реле идет +5 вольт от второго(желтого) блока питания на контакт VCC.

т.е. так

      1          2        3                   4      5     6      7

JD-VCC  VCC  GND             GND IN1 IN2 VCC

1: +5v c синего БП

2: ничего

3: GND с синего БП

4: ничего

5,6: с соответствующей ноги Q0..Q7     74НС595 (на фотках провода: желтый и оранжевый с черными "наконечниками" рядом с 75НС595, никуда не подключены - это Q6 и Q7 (вывел на всякий случай)

7: +5v с жетого БП

Edited by AS7ti6K

Share this post


Link to post
Share on other sites

По хорошему конечно, либо ловить помеху осциллограыом, либо смотреть логическим анализатором что идёт на микруху.

Share this post


Link to post
Share on other sites

Если нужна схема, позже нарисую... сейчас нужно, к сожалению, ехать поработать...

Но на словах добавлю. После обоих БП керамика, а после желтого бп еще и электролит

111.thumb.jpg.e23ad6584f5c3c2a1479d2918b9c7ab0.jpg

Ну и провода коричневый, белокоричневый (+5, GND) идут сразу на 74НС595 там еще скрутка (пропаяна) изолента черная на этих проводах

Провода по цветам по возможности использовал везде одинаково. т.е. I2C - это везде синий/белосиний

А питание коричневый/белокоричневый

6 минут назад, samogon сказал:

По хорошему конечно, либо ловить помеху осциллограыом, либо смотреть логическим анализатором что идёт на микруху.

Нету не того не другого :(

Edited by AS7ti6K

Share this post


Link to post
Share on other sites

@AS7ti6K Ты просто схему нарисуй со всеми соединениями, на словах - невозможно разобраться.

Но, я так понял, ты на 595 питание подал через заднее место. Ещё раз нарисую, как надо было бы сделать:

Обрати внимание на соединение земли arduino и 595! Чёрный провод GND и голубые сигналы - отдельно должен идти! (а не с питания, как у тебя)
5 вольт на оптопары - с питания (ёмкости) 595!
L - небольшой дросселёк, желательно поставить.

 

image.png.3c376901f92f09278028fbfb43764926.png

2 минуты назад, AS7ti6K сказал:

После обоих БП керамика, а после желтого бп еще и электролит

Блоку твои конденсаторы до лампочки! Конденсаторы ставятся у микросхемы! (arduino, 595). А иногда - прямо на выводы питания микросхемы!

Edited by motoandrey14

Share this post


Link to post
Share on other sites

И да, из-за переделок при добавлении второго бп, провода с 74НС пришлось обрезать и впаять в монтажку где и БПшки, а из соседних отверстий вывел на реле зеленые/белозеленые провода. внизу монтажки эти провода соеденены.... линии питания и тем более 220 вольт не пересекаются и между ними есть расстояния, но с учетом строения монтажной платы, может это как-то сказываться?

@motoandrey14  Ок, спасибо за ответ. Но нужно бежать.... Потом вникну, разберусь и отвечу, что понял, что переделал или поясню если у меня правильно, но пошла какая-то непонятка..... изза фоток и неуклюжей (моей) схемы

Share this post


Link to post
Share on other sites

Попробуйте в функции void UpdateChannelState(const byte _bb) поставить задержки защелки.

Share this post


Link to post
Share on other sites

Так, вот только сейчас смог вернуться к данному девайсу. Что сделал пока. Еще раз прозвонил и проверил провода к 74HC595 ни обрывов ни кз и не перепутаны (пины ардуины к ногам регистра)

4 часа назад, Yuriy.pv сказал:

Попробуйте в функции void UpdateChannelState(const byte _bb) поставить задержки защелки.

Если я правильно понял я попробовал так:

void UpdateChannelState(const byte _bb) {
  digitalWrite(pinLatch, LOW);
  delay(10);
  shiftOut(pinData, pinClock, MSBFIRST, _bb);
  delay(10);
  digitalWrite(pinLatch, HIGH);
}

Результата не дало. Так же сначала первое реле срабатывает, потом к нему подключается второе, и затем по два реле сразу срабатывают, Но два раза полностью все тухнут и включаются четко. (Код скеча выше с измененным UpdateChannelState).

Сейчас нарисую схему питания более подробно,  и отвечу @motoandrey14

Share this post


Link to post
Share on other sites
27.11.2020 в 16:25, motoandrey14 сказал:

Ты просто схему нарисуй со всеми соединениями, на словах - невозможно разобраться.

Dev1.jpg.110f0d4dc9853d47169cb6f16a16e667.jpg

Собсно старался выделить только схему питания, хотя там кроме питания ничего особо нет. Сигнальные провода с 74НС595 на реле (на их входы оптопар) объеденил в шину зеленого цвета. Защелку, данные, такты и OE не стал рисовать.   Хотя добавил их в рисунок коричневой шиной. Они сразу в розетку и через витую пару на соответствующие ноги ардуины. Конденсатор под платой 74НС595 между защелкой и землей на данной схеме тоже не стал рисовать. И забыл в схеме соединить MR и VCC сейчас исправлю и заменю рисунок

Вот еще фотки с пометками:

IMG_20201130_132555.jpg.ceaa817d2b633d0dc9ae373602d15a29.jpg

Блоки питания можно поменять местами. Они на разъемах.

IMG_20201130_132607.jpg.5f70c6bcf5e4d0524b978be5fb9ac7a5.jpg

Edited by AS7ti6K

Share this post


Link to post
Share on other sites

Если видели видио, которое я выше ссылкой выложил то на нем видно, что реле срабатывают парами, скеч тоже выше. Или я чего-то не понимаю.... или не соответствует же работа реле со логикой скеча :( И помеха неужели так четко может срабатывать? ...что задваивается сигнал....

@motoandrey14  По поводу твоей переделке схемы, я не совсем понял. Нужно запитывать модули реле в контакт VCC с того же блока, что и в контакты JD-VCC? Питание 595 и ардуины с разных БП? Тогда как-то отпадает необходимость в опторазвязке и вторым блоком в целом... Или я не верно понял изменения. Скорее всего не понял :( 

 

По поводу дросселя - я их никогда не использовал, не знаю(только теоретически с ними знаком) что это такое и как их использовать. Тем более как подбирать номиналы или еще какие ихние параметры.

27.11.2020 в 16:25, motoandrey14 сказал:

Блоку твои конденсаторы до лампочки! Конденсаторы ставятся у микросхемы! (arduino, 595). А иногда - прямо на выводы питания микросхемы!

Учту. Но если от них только нет толку, то уж в этот раз оставлю так, но если это еще и вредно тогда выковырить их?

Edited by AS7ti6K

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Сообщения


  • Адаптеры SOP SSOP TSSOP SOT23 и т.п. на DIP

×
×
  • Create New...